External monitors not working with toshiba dynadock docking station


#1

I’m using manjaro gnome and have it hooked it up to my toshiba dynadock docking station. When I plug in my two monitors into the docking station my laptop does not detect them and the screens remain black. does anyone know if this is a driver issue with the docking station or is there something I need to tweak in manjaro gnome? Also if I plug the monitors directly into my laptop they work just fine so I know it’s not an issue with them.


#2

From terminal:
inxi -Fxxxz
would be a start to identify your hardware and drivers.
According to this old blog post you should not have issues using it, but you might have to install from AUR the displaylink package and probably dl-switch (but i’m not sure about this one tho, as i don’t know your hardware)


#3

here the terminal output

System:    Host: justin-pc Kernel: 4.19.20-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: Gnome 3.30.2 
           wm: gnome-shell dm: GDM 3.30.2 Distro: Manjaro Linux 
Machine:   Type: Laptop System: System76 product: Lemur v: lemu8 serial: <filter> Chassis: type: 10 serial: <filter> 
           Mobo: System76 model: Lemur v: lemu8 serial: <filter> UEFI: American Megatrends v: 5.12 date: 12/08/2017 
Battery:   ID-1: BAT0 charge: 42.3 Wh condition: 42.3/45.3 Wh (93%) volts: 17.2/15.1 model: Notebook BAT type: Li-ion 
           serial: <filter> status: Full 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 8192 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31880 
           Speed: 600 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 600 2: 662 3: 600 4: 601 5: 600 6: 600 7: 600 8: 607 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: CLEVO/KAPOK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
           Display: x11 server: X.org 1.20.3 driver: i915 compositor: gnome-shell resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 18.3.2 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: CLEVO/KAPOK driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:9d71 
           Device-2: DisplayLink type: USB driver: cdc_ncm,snd-usb-audio bus ID: 1-1.1:4 chip ID: 17e9:4305 serial: <filter> 
           Sound Server: ALSA v: k4.19.20-1-MANJARO 
Network:   Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel port: f040 bus ID: 01:00.0 
           chip ID: 8086:24fb 
           IF: wlp1s0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: CLEVO/KAPOK driver: r8168 v: 8.045.08-NAPI 
           port: e000 bus ID: 02:00.1 chip ID: 10ec:8168 
           IF: enp2s0f1 state: down mac: <filter> 
           IF-ID-1: enp0s20f0u1u1i5 state: down mac: <filter> 
Drives:    Local Storage: total: 1.02 TiB used: 8.59 GiB (0.8%) 
           ID-1: /dev/sda vendor: Seagate model: ST1000LM048-2E7172 size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: SDM1 scheme: GPT 
           ID-2: /dev/sdb vendor: Western Digital model: WDS120G1G0B-00RC30 size: 111.79 GiB speed: 6.0 Gb/s serial: <filter> 
           rev: 1000 scheme: GPT 
Partition: ID-1: / size: 92.42 GiB used: 8.59 GiB (9.3%) fs: ext4 dev: /dev/sdb2 
           ID-2: swap-1 size: 17.09 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb3 
Sensors:   System Temperatures: cpu: 29.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 346 Uptime: 7h 47m Memory: 15.54 GiB used: 3.41 GiB (22.0%) Init: systemd v: 239 Compilers: gcc: 8.2.1 
           Shell: bash v: 5.0.0 running in: gnome-terminal inxi: 3.0.30 
[justin@justin-pc ~]$ 

also I tried to download those two packages you mentioned but it gave an error twice and stopped the download


#4

How did you try to download them? From Browser? - don’t do that please. Have a look at what AUR is and how to use it

for a more direct “how to”, from terminal run:
sudp pacman -S trizen base-devel --needed
and reply with yes to ALL = that will install all the necessary packages to enable AUR regardless the DE, and also the wrapper-helper called trizen
Once is done, run:
trizen -S displaylink

You might not need any of the above because you have only an Intel GPU, just add the config is provided in my first link. Did you check it? The file you are looking for to change is located in /etc/X11/xorg.conf.d/ such as 20-intel.conf


#5

sorry I should have specify. I meant I tried to download it from the Add/Remove software app built into gnome


#6

Make sure AUR is enabled in Preferences. Also there might have been some issues with the servers, so try again.