External monitor not connecting Nvidia with Intel Bumblebee

Hi everyone,

My external monitor started to be displayed and my laptop monitor blacked out about a month ago. I’ve tried a few of the methods shown on the forum, including: running Optimus and switching to Nvidia; changing kernel; and reverting back to the default desktop environments.

When I ran Optimus and switched to Nvidia, I would get an error pop up window stating that the driver was not up-to-date in relation to the kernel. Switching kernel removed resolved that issue, but the primary problem still persists.

Switching to nvidia via Optimus results in the external monitor being run (with laggy performance) and the laptop screen blacking out. Switching to integrated or hybrid results in the laptop monitor to be activated and the external monitor to not be detected (after splash screen).

Display configuration only detects one monitor.

I’m new to Linux and unsure which outputs may be useful to the support community. Any help is greatly appreciated.

´´´$ inxi -Fxxx
System: Host: lyndoncompute Kernel: 4.14.234-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.21.5
tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
Machine: Type: Laptop System: LENOVO product: 2436CTO v: ThinkPad W530 serial: Chassis: type: 10
serial:
Mobo: LENOVO model: 2436CTO serial: UEFI-[Legacy]: LENOVO v: G5ETA6WW (2.66 ) date: 08/24/2016
Battery: ID-1: BAT0 charge: 0.8 Wh (100.0%) condition: 0.8/86.6 Wh (0.9%) volts: 11.9 min: 11.1 model: LGC 45N1011
type: Li-ion serial: 50786 status: Full
Device-1: hidpp_battery_0 model: Logitech M720 Triathlon Multi-Device Mouse serial: 405e-3d-6f-98-12
charge: 55% (should be ignored) rechargeable: yes status: Discharging
CPU: Info: Dual Core model: Intel Core i5-3360M bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 cache: L2: 3 MiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 22359
Speed: 1197 MHz min/max: 1200/3500 MHz Core speeds (MHz): 1: 1197 2: 1197 3: 1197 4: 1198
Graphics: Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0
chip-ID: 8086:0166 class-ID: 0300
Device-2: NVIDIA GK107GLM [Quadro K1000M] vendor: Lenovo driver: nvidia v: 465.31 bus-ID: 01:00.0
chip-ID: 10de:0ffc class-ID: 0300
Device-3: Acer ThinkPad Integrated Camera type: USB driver: uvcvideo bus-ID: 1-1.6:4 chip-ID: 5986:02d2
class-ID: 0e02
Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: modesetting,nvidia
resolution: 1600x900~60Hz s-dpi: 96
OpenGL: renderer: NVIDIA Quadro K1000M/PCIe/SSE2 v: 4.6.0 NVIDIA 465.31 direct render: Yes
Audio: Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel
bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403
Sound Server-1: ALSA v: k4.14.234-1-MANJARO running: yes
Sound Server-2: JACK v: 0.125.0 running: no
Sound Server-3: PulseAudio v: 14.2 running: yes
Sound Server-4: PipeWire v: 0.3.28 running: no
Network: Device-1: Intel 82579LM Gigabit Network vendor: Lenovo driver: e1000e v: 3.2.6-k port: 8080 bus-ID: 00:19.0
chip-ID: 8086:1502 class-ID: 0200
IF: enp0s25 state: down mac: 3c:97:0e:83:5a:fd
Device-2: Realtek RTL8188CE 802.11b/g/n WiFi Adapter driver: rtl8192ce v: kernel port: 5000 bus-ID: 03:00.0
chip-ID: 10ec:8176 class-ID: 0280
IF: wlp3s0 state: up mac: a4:17:31:f7:5d:f5
IF-ID-1: br-442bf472b41d state: up speed: N/A duplex: N/A mac: 02:42:1a:b7:06:01
IF-ID-2: docker0 state: down mac: 02:42:cf:4f:af:d9
IF-ID-3: veth19d769f state: up speed: 10000 Mbps duplex: full mac: 5e:e1:df:13:4c:49
IF-ID-4: veth2b89f4b state: up speed: 10000 Mbps duplex: full mac: 7a:19:53:a3:d4:c1
IF-ID-5: veth31b4e00 state: up speed: 10000 Mbps duplex: full mac: b2:96:3c:d2:c1:54
IF-ID-6: veth9acc0f3 state: up speed: 10000 Mbps duplex: full mac: 2a:6a:79:50:be:f9
Bluetooth: Device-1: Broadcom BCM20702 Bluetooth 4.0 [ThinkPad] type: USB driver: btusb v: 0.8 bus-ID: 1-1.4:3
chip-ID: 0a5c:21e6 class-ID: fe01 serial: F4B7E2E6288F
Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
Drives: Local Storage: total: 1.14 TiB used: 120.11 GiB (10.3%)
ID-1: /dev/sda vendor: Samsung model: MZ7TD256HAFV-000L7 size: 238.47 GiB speed: 6.0 Gb/s rotation: SSD
serial: S16GNEAD200934 rev: 4L6Q scheme: MBR
ID-2: /dev/sdb vendor: Western Digital model: WD10JPVX-00JC3T0 size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm
serial: WD-WXB1A2497077 rev: 1A01 scheme: MBR
Partition: ID-1: / size: 233.72 GiB used: 120.11 GiB (51.4%) fs: ext4 dev: /dev/sda1
Swap: Alert: No swap data was found.
Sensors: System Temperatures: cpu: 48.0 C mobo: N/A gpu: nvidia temp: 44 C
Fan Speeds (RPM): cpu: 0
Info: Processes: 194 Uptime: 5m wakeups: 4 Memory: 15.23 GiB used: 2.13 GiB (14.0%) Init: systemd v: 247 Compilers:
gcc: 11.1.0 clang: 11.1.0 Packages: pacman: 1647 Shell: Bash v: 5.1.8 running-in: yakuake inxi: 3.3.04
´´´

For the NVIDIA GK107GLM [Quadro K1000M] with kernel <5.4, the 390xx driver is the correct one and not the 465xx. Bumblebee (in your headline) only makes sense if the external monitor on the Lenovo W530 is connected to the VGA port. But you’re also talking about Optimus and switching to integrated or hybrid at the same time.
It is not clear which way you want to go.

Thank you for your reply. Yes, the external monitor is usually connected to the VGA port.
I don’t mind going in any which way that will allow me to use both the external monitor and laptop monitor at the same time. I suppose whichever method is easiest/most straightforward from here on in?
Which method would you suggest?

I would want to use the energy-saving technology of the Nvidia and also the display port or, with Lenovo Dockingstation, the HDMI connection. The Optimus-manager-qt is very suitable for this. By the way: your name says that you speak german? Gerne auch hier im deutschen Foren Bereich…

1 Like

EDIT: Back to the same problem after an update. The post below was only solved the problem until the next update. The ‘solution’ I posted does not currently work.

Solved (although not entirely): from the aforementioned circumstance, I:

  1. swapped one external monitor for a new one;
  2. in Optimus I switched to Hybrid;
  3. set to launch in Hybrid rather than Nvidia in Optimus

I’m still puzzled about the cause of the original issue and why I couldn’t resolve the issue on my old monitor - anyone who may read this and know the answer/solution, please message me!

I think I’ve located the problem and, after a little testing, found the solution!

The first fix came from a hardware problem. The power adapter for my external monitor did not exactly have the same output as the monitor. This wasn’t a problem in the past (have been using it with my monitor for about 6 months) but after an update or (some aging?) it caused compatability issues with the laptop and the VGA card. Someone might have a better explanation for this, however after trying other adapters, I finally located one with the specific power output.

Having the exact power output permitted the external monitor, when Optimus was switched to Nvidia, to become the primary one and the laptop monitor to become secondary. The laptop monitor would simply allow a black screen and cursor. However, windows could be dragged from the external monitor to the laptop one and be worked on as per usual. Splash and reboot screens would also pop up on the laptop monitor.

To resolve this issue (said black screen with cursor problem), I:

  1. deleted all nvidia related installations via system settings> hardware configuration and through Pamac with an nvidia search.
  2. double checked the kernel via uname -a
  3. via the Pamac GUI, searched for installed the most up-to-date Nvidia driver, as per the output of uname -a
  4. Having noticed that there was no change after rebooting, I switched Optimus to Hybrid and the problem was solved.
  5. Changed the settings in Optimus to launch via Hybrid.

Please note that I followed Denshi Video’s walkthrough for installing Optimus on Manjaro KDE, which was very helpful. However, I have since learnt that the yay -S nvidia command did not provide the most up-to-date driver – I found them via the Pamac GUI. This turned out to be an important tweak.

Thanks everyone!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.