External monitor is not detected

Hello everyone,

I’m writing to you because I’m having trouble with my screen. I’m on a laptop, and an external screen is undetected when I plug it in.

I use X11.

    ~  echo $XDG_SESSION_TYPE                                                                                                                 ✔ 
x11
    ~  glxinfo | grep server                                                                                                                  ✔ 
server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
    ~    
    ~  xrandr                                                                                                                             127 ✘ 
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1920x1080    144.00*+  60.00 +  59.97    59.96    59.93  
   1680x1050     59.95    59.88  
   1400x1050     74.76    59.98  
   1600x900      59.99    59.94    59.95    59.82  
   1280x1024     85.02    75.02    60.02  
   1400x900      59.96    59.88  
   1280x960      85.00    60.00  
   1440x810      60.00    59.97  
   1368x768      59.88    59.85  
   1280x800      59.99    59.97    59.81    59.91  
   1152x864      75.00  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      85.00    75.05    60.04    85.00    75.03    70.07    60.00  
   1024x768i     86.96  
   960x720       85.00    75.00    60.00  
   928x696       75.00    60.05  
   896x672       75.05    60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   832x624       74.55  
   960x540       59.96    59.99    59.63    59.82  
   800x600       85.00    75.00    70.00    65.00    60.00    85.14    72.19    75.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   700x525       74.76    59.98  
   800x450       59.95    59.82  
   640x512       85.02    75.02    60.02  
   700x450       59.96    59.88  
   640x480       85.09    60.00    85.01    72.81    75.00    59.94  
   720x405       59.51    58.99  
   720x400       85.04  
   684x384       59.88    59.85  
   640x400       59.88    59.98    85.08  
   576x432       75.00  
   640x360       59.86    59.83    59.84    59.32  
   640x350       85.08  
   512x384       85.00    75.03    70.07    60.00  
   512x384i      87.06  
   512x288       60.00    59.92  
   416x312       74.66  
   480x270       59.63    59.82  
   400x300       85.27    72.19    75.12    60.32    56.34  
   432x243       59.92    59.57  
   320x240       85.18    72.81    75.00    60.05  
   360x202       59.51    59.13  
   360x200       85.04  
   320x200       85.27  
   320x180       59.84    59.32  
   320x175       85.27  
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)

I think the problem may be related to this:

    ~  systemctl status optimus-manager                                                                                                       ✔ 
Unit optimus-manager.service could not be found.

There is some info about my system.

I am looking forward to the guides. Thanks in advance for your help!

Mykhailo.

Hi @MOrydoroha, and welcome!

I think you are correct, because in your system information, forr the Nvidia card, it states:

driver: N/A

So I think you are correct. But there might be a driver available for it. Please provide the output of:


mhwd --listinstalled

And

mhwd --list

…please.


:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Thank you for the fast reply!

Here is the requested info:

mhwd --listinstalled                                                                                                                   
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
     video-modesetting            2020.01.13                true            PCI


Warning: No installed USB configs!
mhwd --list                                                                                                                           
> 0000:37:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2023.09.12                true            PCI


> 0000:01:00.0 (0300:10de:28e0) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-prime            2023.03.23               false            PCI
          video-nvidia            2024.05.03               false            PCI
           video-linux            2024.05.06                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI


> 0000:00:02.0 (0300:8086:46a6) Display controller Intel Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-prime            2023.03.23               false            PCI
           video-linux            2024.05.06                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

may you also post the followings

inxi --admin --verbosity=7 --filter --no-host --width

and

glxinfo | grep server && echo $XDG_SESSION_TYPE

inxi --admin --verbosity=7 --filter --no-host --width

glxinfo | grep server && echo $XDG_SESSION_TYPE                                                                                   

server glx vendor string: SGI
server glx version string: 1.4
server glx extensions:
x11

the nvidia-driver is missing as you can read in the inxi

Device-2: NVIDIA AD107M [GeForce RTX 4060 Max-Q / Mobile] vendor: ASUSTeK
    driver: N/A alternate

you should install the propietary driver first

sudo mhwd -a pci nonfree 0300 

as desribed in the wiki

afterwards install envycontrol

pamac install envycontrol

and switch to nvidia

sudo envycontrol -s nvidia
sudo mhwd -a pci nonfree 0300

[sudo] password for morydoroha: 
> Using config 'video-hybrid-intel-nvidia-prime' for device: 0000:01:00.0 (0300:10de:28e0) Display controller nVidia Corporation 
> Using config 'video-hybrid-intel-nvidia-prime' for device: 0000:00:02.0 (0300:8086:46a6) Display controller Intel Corporation 
> Installing video-hybrid-intel-nvidia-prime...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-prime/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
:: Synchronizing package databases...
 core downloading...
 extra downloading...
 multilib downloading...
warning: nvidia-utils-550.90.07-7 is up to date -- skipping
warning: nvidia-prime-1.0-4 is up to date -- skipping
warning: lib32-nvidia-utils-550.90.07-2 is up to date -- skipping
warning: linux419-nvidia-550.90.07-4 is up to date -- skipping
warning: linux61-nvidia-550.90.07-5 is up to date -- skipping
error: target not found: linux65-nvidia
Error: pacman failed!
Error: script failed!

try to force the installation

sudo mhwd -f -i pci video-hybrid-intel-nvidia-prime

Still failing

sudo mhwd -f -i pci video-hybrid-intel-nvidia-prime
> Installing video-hybrid-intel-nvidia-prime...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-prime/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
:: Synchronizing package databases...
 core downloading...
 extra downloading...
 multilib downloading...
warning: nvidia-utils-550.90.07-7 is up to date -- skipping
warning: nvidia-prime-1.0-4 is up to date -- skipping
warning: lib32-nvidia-utils-550.90.07-2 is up to date -- skipping
warning: linux419-nvidia-550.90.07-4 is up to date -- skipping
warning: linux61-nvidia-550.90.07-5 is up to date -- skipping
error: target not found: linux65-nvidia
Error: pacman failed!
Error: script failed!

that’s the problem, the kernel 6.5 is eol (end of live). you need to update your system to an actual kernel first.

1 Like

Thank you so much!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.