External monitor detected, but no signal

I’m currently on my laptop (HP Pavilion Gaming 15) with the following configurations:
Integrated GPU: AMD Radeon Vega 8
Discrete GPU: NVIDIA GeForce GTX 1650 Mobile / Max-Q
I’m currently on Linux kernel 5.10.7-3 and KDE Plasma 5.20.5

The issue is simple, I have dual booted this laptop and the external display works well with windows. However, the monitor is detected by my Manjaro but still there’s no output! I know that the monitor is being detected because I can see the monitor in my Display Configuration, and also here’s an output of xrandr

Screen 0: minimum 320 x 200, current 3285 x 1080, maximum 16384 x 16384
eDP connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1920x1080     60.01*+  40.00  
   1680x1050     60.01  
   1280x1024     60.01  
   1440x900      60.01  
   1280x800      60.01  
   1280x720      60.01  
   1024x768      60.01  
   800x600       60.01  
   640x480       60.01  
HDMI-A-0 disconnected (normal left inverted right x axis y axis)
HDMI-1-0 connected (normal left inverted right x axis y axis)
   1366x768      59.79 +
   1920x1080     59.94  
   1280x1024     75.02    60.02  
   1280x720      59.94  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x480       59.94    59.94  
   640x480       75.00    72.81    59.94 

Here’s an output of inxi -Faz

System:    Kernel: 5.10.7-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 root=UUID=7dfd0bce-9d56-4106-9654-245e95857567 rw quiet 
           apparmor=1 security=apparmor udev.log_priority=3 acpi_backlight=vendor 
           Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-ec0xxx v: N/A serial: <filter> Chassis: 
           type: 10 serial: <filter> 
           Mobo: HP model: 86D5 v: 96.44 serial: <filter> UEFI: AMI v: F.10 date: 08/25/2020 
Battery:   ID-1: BAT0 charge: 47.3 Wh condition: 47.3/47.3 Wh (100%) volts: 12.8/11.6 
           model: Hewlett-Packard Primary type: Li-ion serial: N/A status: Full cycles: 425 
CPU:       Info: Quad Core model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx bits: 64 type: MT MCP 
           arch: Zen/Zen+ note: check family: 17 (23) model-id: 18 (24) stepping: 1 microcode: 8108109 
           L2 cache: 2 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 33547 
           Speed: 1222 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 1: 1222 2: 1222 3: 1223 4: 1220 
           5: 1222 6: 1222 7: 1221 8: 1222 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: disabled, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] vendor: Hewlett-Packard driver: nvidia 
           v: 460.32.03 alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1f91 
           Device-2: Advanced Micro Devices [AMD/ATI] Picasso vendor: Hewlett-Packard driver: amdgpu v: kernel 
           bus ID: 04:00.0 chip ID: 1002:15d8 
           Device-3: Quanta HP TrueVision HD Camera type: USB driver: uvcvideo bus ID: 3-1:2 chip ID: 0408:5365 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: amdgpu,ati,nvidia 
           unloaded: modesetting,nouveau alternate: fbdev,nv,vesa display ID: :0 screens: 1 
           Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.9x11.2") s-diag: 581mm (22.9") 
           Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") diag: 394mm (15.5") 
           OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.40.0 5.10.7-3-MANJARO LLVM 11.0.1) 
           v: 4.6 Mesa 20.3.3 direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor 
           vendor: Hewlett-Packard driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus ID: 04:00.5 
           chip ID: 1022:15e2 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Hewlett-Packard driver: snd_hda_intel 
           v: kernel bus ID: 04:00.6 chip ID: 1022:15e3 
           Sound Server: ALSA v: k5.10.7-3-MANJARO 
Network:   Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Hewlett-Packard 
           driver: rtw_8822ce v: N/A modules: rtw88_8822ce port: e000 bus ID: 02:00.0 chip ID: 10ec:c822 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 
           v: kernel port: d000 bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: eno1 state: down mac: <filter> 
Drives:    Local Storage: total: 1.16 TiB used: 34.75 GiB (2.9%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-60Z10T0 size: 931.51 GiB block size: 
           physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 1A04 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital model: WDS240G2G0B-00EPW0 size: 223.58 GiB 
           block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 0000 
           ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: SanDisk model: Ultra size: 28.64 GiB block size: 
           physical: 512 B logical: 512 B serial: <filter> rev: 1.00 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Partition: ID-1: / raw size: 44.75 GiB size: 43.8 GiB (97.87%) used: 34.75 GiB (79.3%) fs: ext4 dev: /dev/sdb6 
           maj-min: 8:22 
           ID-2: /boot/efi raw size: 256.9 MiB size: 253 MiB (98.46%) used: 301 KiB (0.1%) fs: vfat dev: /dev/sdb5 
           maj-min: 8:21 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 53.2 C mobo: N/A gpu: amdgpu temp: 53.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 269 Uptime: 43m wakeups: 1 Memory: 9.67 GiB used: 2.14 GiB (22.1%) Init: systemd v: 247 
           Compilers: gcc: 10.2.0 Packages: 1346 pacman: 1340 lib: 408 flatpak: 0 snap: 6 Shell: Bash v: 5.1.0 
           running in: konsole inxi: 3.2.02

I have Optimus Manager Qt and I’ve tried going full integrated too, but still no luck. Can someone please help me out :pray: