External monitor black screen!

I just installed Manjaro on my laptop and I noticed that I have a problem when I connect a external monitor to the HDMI port of the laptop. When I connect it, apparently all works, but the external monitor is black, I can move the mouse and windows to that screen but I’m not able to see nothing because is just black. The monitor of the laptot works perfectly.

glxinfo | grep OpenGL

OpenGL vendor string: X .Org
OpenGL renderer string: AMD RAVEN (DRM 3.38.0, 5.8.6-1-MANJARO, LLVM 10.0.1)
OpenGL core profile version string: 4.6 (Core Profile) Mesa 20.1.7
OpenGL core profile shading language version string: 4.60
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 4.6 (Compatibility Profile) Mesa 20.1.7
OpenGL shading language version string: 4.60
OpenGL context flags: (none)
OpenGL profile mask: compatibility profile
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.2 Mesa 20.1.7
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20
OpenGL ES profile extensions:

xrandr --listmonitors

Monitors: 2
0: +*eDP 1920/344x1080/193+0+0 eDP
1: +*HDMI-1-0 1920/598x1080/336+1920+0 HDMI-1-0

inxi -G

Graphics:
Device-1: NVIDIA TU106M [GeForce RTX
2060 Mobile]
driver: nvidia v: 450.66
Device-2: AMD Picasso driver: amdgpu
v: kernel
Device-3: IMC Networks USB2.0 HD UVC
WebCam
type: USB driver: uvcvideo
Display: x11 server: X .Org 1.20.8
driver: amdgpu,nvidia FAILED: ati
unloaded: modesetting,nouveau
resolution: 1: 1920x1080~120Hz
2: 1920x1080~60Hz
OpenGL: renderer: AMD RAVEN (DRM
3.38.0 5.8.6-1-MANJARO LLVM 10.0.1)
v: 4.6 Mesa 20.1.7

I have actually installed that drivers:

  • video-hybrid-amd-nvidia-450xx-prime
  • video-linux
  • video-modesetting

Could you help me? Thanks in advance!

As you didn’t provide an inxi --admin --verbosity=7 --filter --no-host I can only speculate that the HDMI port is only being driven by the nVidia card (happens on a lot of laptops) and you need optimus-manager to enable the nVidia for compositing instead of prime-run for single applications, so read the blurb above and then install using:

pamac install optimus-manager

after you activate the AUR

:innocent:

I know what you’re talking about. There is no technical issue, you just haven’t “configured” the screen yet. You can set a background and and a Tasktar to the second screen if you wish, or just leave it blank.