[experimental] Manjaro-Architect Test-ISO

development
netinstall
manjaro-architect

#165

It exists, I am using fish so I will try installing it before creating the user.


#166

:wink:


#167

I was logging in via console. I am using systemd. I think that it has to do with the fact that I use fish and it wasn’t installed upon creating the user.


#168

See my link above your last post. We just took care of that :slight_smile:


#169

Awesome ^×^


#170

You work so fast, you ppl at manjaro are really amazing. ^^


#171

@oberon is a beast, as are all the Manjaro Devs + Team :smiley:


#172

I tried again this morning and made sure that fish was installed both in the live environment and on the target disk before creating my user but I still cannot login to it. In the user directory there are no folders like Documents, Downloads etc. However there are some hidden config files.


#173

I could try and re-create this issue and assist diagnosis.

Can you please list the exact steps you perform during manjaro-architect install, and I’ll try and re-create your issue in my VM testing environment.


#174

Will a logfile help, or do you want me to type it out? ^×^ ty for help.


#175

Are you re-installing the system from scratch each time, or just mounting partitions and only adding the user?

As detailed a description as possible would certainly help. If I do exactly the same as you and get the same issue I’ll have an environment to assit debugging.

Maybe copy and paste my installation procedure from this post and change the details you do differently.


#176

Login to the live environment
I run sudo pacman - Syu fish fisherman
setup
I select English
Prepare installation, I mount my partitions, sda1 is / and is btrfs with no mount options, swap sda2
Install base, configure mirrorlist, rank by speed, I select unstable.
Refresh pacman keys
Install base, select 4.10 and base-devel, kernel-headers, kernel-acpi_call, kernel-broadcom-wl
Install bootloader, grub on sda
Install desktop environment, install display driver, select video-nouveau
Advanced installation, install unconfigured de, install custom packages, I install fish, fisherman
Configure base, generate fstab, device uuid,
Set hostname, "doris"
Set system locale, en_us
Set timezone, Europe, Stockholm, utc
Set root pw, "123"
Add user, “emi”, select fish, pw, "123"
Run mkinitcpio
Done


#177

I will try your installation procedure, I am re-installing between every try.


#178

I’ll give yours a run, changing drivers to suit.


#179

From your description I don’t understand what you are trying to install, and how you are trying to install it.

You are attempting to install

  • Linux 4.10 base on btrfs partition, hostname doris
  • User emi, pwd 123, fish shell, root pwd 123
  • Unconfigured LxQt DE, or Manjaro LxQt DE?

Is this right?


#180

I installed it without any de just to try it this morning.


#181

I do just a base install.

base + base-devel + virtualbox-guest
install default bootloader EFI
configure base + create 3 users (zsh,bash,fish)

Install and startup are fine now with latest version 2-3 days ago
User: zsh + bash are ok with fix from yesterday
User: fish still not able to login and no particular error in the journal (fish is installed during user creation)

03/06/17 10:54:34 set_root_password New password: Retype new password: passwd: password updated successfully
03/06/17 10:54:46 default shell: [zsh]
03/06/17 10:54:58 add user to groups
03/06/17 10:54:58 create user pwd New password: Retype new password: passwd: password updated successfully
03/06/17 10:55:08 default shell: [bash]
03/06/17 10:55:19 add user to groups
03/06/17 10:55:19 create user pwd New password: Retype new password: passwd: password updated successfully
03/06/17 10:55:30 default shell: [fish]
03/06/17 10:55:41 add user to groups

[2017-03-06 10:54] [PACMAN] Running ‘pacman -r /mnt -Sy --noconfirm manjaro-zsh-config’
[2017-03-06 10:54] [PACMAN] synchronizing package lists
[2017-03-06 10:54] [ALPM] transaction started
[2017-03-06 10:54] [ALPM] installed zsh (5.3.1-1)
[2017-03-06 10:54] [ALPM] installed zsh-autosuggestions (0.3.2-1)
[2017-03-06 10:54] [ALPM-SCRIPTLET] To activate zsh-autosuggestions add the following line at the end of ~/.zshrc:
[2017-03-06 10:54] [ALPM-SCRIPTLET] source /usr/share/zsh/plugins/zsh-autosuggestions/zsh-autosuggestions.zsh
[2017-03-06 10:54] [ALPM] installed zsh-syntax-highlighting (0.5.0-1)
[2017-03-06 10:54] [ALPM-SCRIPTLET] To activate zsh-syntax-highlighting, add the following line at the end of ~/.zshrc:
[2017-03-06 10:54] [ALPM-SCRIPTLET] source /usr/share/zsh/plugins/zsh-syntax-highlighting/zsh-syntax-highlighting.zsh
[2017-03-06 10:54] [ALPM] installed zsh-completions (0.23.0-2)
[2017-03-06 10:54] [ALPM] installed zsh-history-substring-search (1.0.0-1)
[2017-03-06 10:54] [ALPM-SCRIPTLET] ==> To use, load the script (running terminal or /root/.zshrc):
[2017-03-06 10:54] [ALPM-SCRIPTLET]
[2017-03-06 10:54] [ALPM-SCRIPTLET] source /usr/share/zsh/plugins/zsh-history-substring-search/zsh-history-substring-search.zsh
[2017-03-06 10:54] [ALPM-SCRIPTLET]
[2017-03-06 10:54] [ALPM-SCRIPTLET] ==> If you also want to use zsh-syntax-highlighting, make sure you load
[2017-03-06 10:54] [ALPM-SCRIPTLET] ==> it before you load this script.
[2017-03-06 10:54] [ALPM] warning: directory permissions differ on /mnt/root/
filesystem: 750 package: 755
[2017-03-06 10:54] [ALPM] installed manjaro-zsh-config (0.4-2)
[2017-03-06 10:54] [ALPM] transaction completed
[2017-03-06 10:54] [ALPM] running ‘systemd-update.hook’…
[2017-03-06 10:55] [PACMAN] Running ‘pacman -r /mnt -Sy --noconfirm fish’
[2017-03-06 10:55] [PACMAN] synchronizing package lists
[2017-03-06 10:55] [ALPM] transaction started
[2017-03-06 10:55] [ALPM] installed bc (1.06.95-3)
[2017-03-06 10:55] [ALPM] installed fish (2.5.0-1)
[2017-03-06 10:55] [ALPM] transaction completed

Virtualbox-guest does not get installed, need to check the logs but can be linked to the fact you need to choose the modules depending on your kernel.


Does nothing:

03/06/17 10:44:46 packages to install: acpi b43-fwcutter bash btrfs-progs bzip2 coreutils crda dhclient diffutils dmraid dnsmasq dosfstools e2fsprogs ecryptfs-utils exfat-utils f2fs-tools file filesystem findutils gawk gcc-libs gettext glibc grep gzip inetutils intel-ucode iproute2 iptables iputils ipw2100-fw ipw2200-fw jfsutils less licenses linux-firmware logrotate lsb-release man-db manjaro-firmware manjaro-release manjaro-system man-pages memtest86+ mhwd mhwd-db mkinitcpio-openswap nano nilfs-utils ntfs-3g os-prober pacman pciutils pcmciautils perl procps-ng psmisc reiserfsprogs sed shadow s-nail sudo sysfsutils acpid cpupower cronie cryptsetup device-mapper dhcpcd haveged lvm2 mdadm nfs-utils rsync systemd-sysvcompat tlp wpa_supplicant tar texinfo usbutils util-linux which xfsprogs zd1211-firmware linux410 base-devel
03/06/17 10:53:28 install basepkgs ==> Creating install root at /mnt

EDIT: actually none of the kernel options got installed. acpi_call and ndiswrapper neither.


Manjaro-architect 0.8
#182

When, I typed “install unconfigured de” I was referring to the steps in the menu. Sorry for being unclear.


#183

The install you linked works nicely. I had no problem logging in.


#184

So it seems like the fact that I am using fish is the problem, right? ^ ^