[experimental] Manjaro-Architect Test-ISO

development
netinstall
manjaro-architect

#145

Well today I tried out manjaro-architect on one of my home laptops. It was a 6gb HP Elitebook 2530p with 128gb hdd. I was able to install manajro w/windowmaker but I don’t quite like the look of windowmaker so I went back and redid it as lxqt desktop. I noticed a couple of things when trying it out today. First I was given the option of a standard or advanced installation which is neat. I tried both of them and I personally like the advanced a little bit better because it gives you better control of what and how things are installed but the standard version should be a great boon to those who have machines and want to install manjaro but for whatever reason they can’t use Calamares. The second thing I noticed is during the auto partition it creates a boot sector and I haven’t been doing that when I have been manually partitioning the disk. I say because I was working on UEFI build at work with 2 hdds and I couldn’t get it to boot and believe it is because I didn’t create a boot sector. I’ll fix that when I go back to work. Thanks again for the great work on this ISO. I love the fact that it will always be update so once it is “stable” I don’t have to download new Mnajaro ISOs every so often if I need to reinstall Manjaro or if I want to install it on a new machine.
Edit: i just realized that it didn’t install pulseaudio and I am having to do that now. I know when I did the advanced install I installed them and I thought I did in the standard but I might have missed it unless that is not an option in the standard install.
Edit; I did do the minimal install so those things were properply not included. Anywya keep up the great work!


#146

That’s by design in the lxqt-profile… :slight_smile:


#147

The ISO has now been maiarized … :sunglasses:

the menu colors still need a little tweaking …

in any case, I’ll upload a new version of the ISO tonight …


#148

Didn’t know that. Cool it is good to learn something new😉


#149

I am having a problem logging in to the os after installing the unconfigured version of lxqt. It says I don’t have the correct password. Though I works fine to log in as root which is using the same password. I suspected first that it could be something with keyboard layouts so I have also tried this with passwords like “123” (which is same on both layouts) yet it still doesn’t work. Has anyone experienced anything like this? I hope I am posting this in the right place.


#150

I have tried this with a barebones install without any gui and I am having the same problem, yet if I use a manjaro version at the desktop environment stage of the installation everything works fine


#151

Did you create your own user at install?


#152

Yes I did. It is really wierd


#153

Username and password I tried with what: u=emi p=123


#154

Since the new iso was released, the installer does not seem to create a user for me. Tried with a stable manjaro lxqt version, with the same options that worked a few days ago.


#155

I think it’s as mentioned in the other thread. This issue should be fixed in the latest version:


#156

You can go back into the installer mount your drives do not format go to users and setup your user name, don’t forget to press add new user button, well that is how architect worked never any need to reinstall for mistakes.


#157

in this case I think, because the version with the bug was used, user home just needs to be chowned:

sudo chown -R <username>:<username> -R /home/<username>

(from target install - so since you can log in as root only anyway, without sudo … :wink: )


#158

Oki I see ^ ^ ty for the help, I will try to fix it that way.


#159

I tried again with a clean install and ran upon the same problem as before. I tried your method with:[quote=“oberon, post:157, topic:17661”]
chown -R username:username -R /home/username
[/quote]

But I still cannot login. I made sure that I updated the installer before using it. So I am not sure if the problem is fixed in the installer.


#160

Is this systemd or openrc? Do you login with displaymanager or in the console? Did you install lxqt or create the user first?


#161

By default the user is created with zsh shell, but zsh is not installed at that moment. If zsh is not installed afterwards the user can not login.


#162

good point. we need to make sure after selection that the selected shell does in fact get installed :wink: or are we? need to check that!


#163

Does the user home exist at all or has it not been created?


#164

I was do able to do a lxqt build yesterday with no issues but i didn’t use zsh shell i chose bash. I installed the desktop first then added the user and password. Trying using the bash shell instead zsh and see what happens