[experimental] Manjaro-Architect Test-ISO

development
netinstall
manjaro-architect

#125

[quote=“mandog, post:122, topic:17661”]
Next time its only mins + when it becomes final…[/quote]
It sounds like you are saying that when the project becomes more refined, it will not take as long to install a new system. WIll enjoy seeing the progress on that issue.

…you get a system built by you , not dictated by somebody else.

Mandog, this may be a case where a system “built by someone else” is a blessing and great boost, rather than the harsh result of a dictator. To my taste the Gellivara/17.0 i3 Manjaro .iso is a great balance of size and comprehensiveness, my own judgement (and that of so many newbies) as to what to include would not be as good as the Team’s + Calamares. Typically am installing the .iso (exactly 7 minutes for an SSD install), changing to 4.10, installing evince, libgsf, dash, libreoffice, opera and imagewriter (another 4 minutes) and am off to the races. Well maybe a printer driver and SANE too.


#126

This installer if you research is more for experienced users than for new users.

Put it another way I can use the architect ISO that is 2 years old it will update and install the latest arch packages and scripts to build my system and its up to date, I can install arch the arch way with a old ISO it will install the latest packages and scripts.
I can’t use a old Manjaro ISO and get the latest packages and scripts its out of date as its a fixed release of a snapshot.
the Manjaro-architect installer is a extension of the original Architect installer to install Manjaro the architect- arch way
Its for experienced users one step up from the net install for users that want more control and a step nearer the arch way for Manjaro.


#127

You’ll be able to do this with 17.0 release and calamares, but only for lxqt currently, both for openrc and systemd lxqt. Plus, you can use same iso to install cli only system.


#128

I know you are working on LXQT but will it include all popular de in that case you should all work together not fight over it?


#129

I tried today Manjaro-Architect (OpenRC, Xfce minimal) on one old and complicated desktop, on which last 7-8 installations with latest Calamares versions didn’t work. Every single installation with newer Calamares didn’t work. Looks like something is wrong with boot flagging. When I manually changed it with gparted, those installations worked. I only have this problem on this strange and complicated old rusted box!

Well, Manjaro-Architect don’t have this problem. After installation I got boot menu as I should. Bravo! :+1:
If it works on THIS desktop, it will work on any machine :slight_smile:

The only thing is, I can atest, it is not quite yet dummy proof. :wink:
I managed to mess something up. I didn’t know how to set user and it’s password. Should I edit one of those config files at the end of installation?

So now I’m sort of locked out at log in menu lol.
I will wait until you make it more dummy proof, then I will try again.

Good job, btw, I like it how you have so many options, feels like you really are in charge :wink:


#130

The process basically mirrors the steps involved for an Arch install, but in menu form.

I really like it, a few rough edges to be ironed out, but the potential is enormous.

Whilst it should be fault tolerant, and provide completeness checking before exit, it should not be necessarily “dummy proof”. If users want a simple, straight forward install media then a Calmares ISO is what they should be using.

Agree.

This installer allows a user to make explicit choices to setup their system exactly how they wish, if they make foolish decisions then it should not be up the the installer to capture these.


#131

Yes I know, I was being a little smart-alicky. But dummy or no dummy proof, one day this dummy will install it! :grinning:

Hey, you made some quite extensive testing (thank you) how do you set up user and it’s password? By editing one of the configuration files at the end of the installation?


#132

In the installer it happens in the “Configure base” menu. To do it manually, use useradd and passwd commands:

https://wiki.archlinux.org/index.php/Users_and_groups#User_management


#133

Ahh, I must off missed that step. Thank you! (and for the link for manual setup)


#134

You can also also generate fstab and set root password there :slight_smile:


#135

An excellent way to put this project in perspective. Interesting that Manjaro project attracts good communicators.


#136

This depends only on a decision by other maintainers to go netinstall.
Currently, lxqt team decided to do netinstall, drop classic unsquashing, ie the iso lasts longer.
Who is fighting?


#137

Yeah. Looks really great and we have many different options now. Just needs some more time to adjust for the other editions aswell. Lately I was just rather busy with the architect :wink:


#138

Interesting, thanks!


#139

Only joking about fighting :grinning:
Normal users don’t grasp the idea about net install whether it comes from they were mainly fixed release users before Manjaro they don’t get you do not need to download the net installer ISO every time you install like on a monthly basis.


#140

The problem lies within the approach in my opinion.
I noticed that too, people come here and ask the same questions over and over again. Mainly, "can I update from version XY to version ZA"
Its after all a rolling release, and you can write it in big fat letters on every wall, it won’t be read, and the versioning of rolling doesn’t make this misconception go away.


#141

Maybe change the wording of the download section.

“Stable releases” gives the impression that the rest is not stable.


#142

Which they aren’t necessarily. We just often have no real problems in testing and unstable branches. After all, unstable is stable on arch.
Wording is one thing, getting rid of misconceptions is difficult, and requires acknowledgement, that misconceptions are created.
Rolling distro means, you install once, and never again.


#143

I agree, then the terms “stable” and “releases” makes no sence for an installer.
All the persons reporting errors with an install media 16.10.x are answered you should try with 17.x instead.


#144

Oh yes it does, @Onf, because what it means in this thread is that the installer, manjaro-architect is a new development and the application is still unstable. Soon it will be ready for testing branch and once it is stable you can (hopefully) use it to install a system… :wink: