[experimental] Manjaro-Architect Test-ISO

development
netinstall
manjaro-architect

#61

is this in the live session of the ISO?


#62

The latest iso is faulty

I got the same error and when git’ing I got bash errors

Also tried to build the iso but the package is completely missing from unstable rep.

So I will turn to other matters for a while :slight_smile:


#63

Hm. Downloaded one a few days ago, that worked fine…


#64

yes it is.
Edit I just tried the iso had downloaded on Monday and it was the same issue


#65

There was a syntax error in the git. Fixed now. Once the package in unstable gets updated, the iso you now have should start working. It begins by downloading the latest version.


#66

Sorry for that. I was out during the day. Package is rebuilt now: 0.7.4.r123.gdce2519


#67

Ok it’s working again


#68

I was able to install lxqt but I didn’t install login manager then I also messed up the disk partition I think I should have chosen gpt for UEFI but I didn’t so grub didn’t boot. I am going to start and partition my disk properly


#69

Use the manjaro lxqt profile, it comes with display manager enabled


#70

I was able to succesfully install a full LXQT desktop. I was lazy and I did the auto partition which seemed work ok.


#71

Installation with nonfree (catalyst) drivers failed, successful with free drivers


#73

I was able to install openrc KDE minimal. Manual partition, free graphic, drivers and no bootloader. Installer seemed to take me through twice but after updating grub everything works great.

db


#74

Bare-Metal [simple] install, using the manjaro-architect iso in this thread:
Hardware:
Asus Laptop: UEFI, with 2 Sata HD’s, sda, and sdb.
WiFi only: Atheros AR9485, which has been supported forever in Linux.

At first:

  • ran sudo setup, #ended up with manjaro-architect .3 version ?, with my SATA HD’s labelled as sdb, and sdc, which is not correct. ?

Rebooted,
ran sudo “systemctl enable NetworkManager.service”, then ran
sudo setup, # got manjaro-architect latest versio .7.4.xxxx, with SATA HD’s labeledd as sda, and sdb. -which is correct.

  • I selected the “Wipe disks clean” option, but it sat at 0% for 10 minutes, so not working. ?

Went back selected cgdisk, [gpt], and manually deleted old parttions, and re-added new “/” parttion [sda2], and swap [sda3] partition on sda, including /boot/[efi] on [sda1], and everything went fine.

  • pacman rank-mirrors allowed me to select several fast repo’s, but it didn’t show up in “edit mirrolrlist” after, maybe it had saved it in /tmp/xxx… ?

-Anyway, upon completetion, and reboot of installation, the /etc/pacman.d/mirrolrlist was correctly copied over exactly as i chose them -so that’s good.

The rest of the install of Manjaro/KDE stable, FULL, but with 4.9 .* kernel, along with Plasma went great.
I think I accidently did it twice, umm, that part was my fault, but still, over-correcting can cause this potenial User error of doing needless “graphical install profiles” twice over ? :wink:

Note: the “cancel”, and “back” buttons seem to be more “user-freindly / lively” this time around, which is extremely handy if a User thinks they’ve made a mistake.
Keep it up !.

  • Also, I couldn’t find that manjaro-architect installer log file upon post-installation/reboot on the target system?
    Is it called “m-a.log” ???

Anyway, sry for the undetaled decription above, but that’s my quick take on this manjaro-architect netinstall iso thus far, using by 5-key broken keyboard, with “florence”. :wink:

So if any Dev is actually interested in this, and obviously hasn’t tested further, then here you go, all edits included.


#75

I did another bare metal install on the same Dell I used earlier and this time I used cgdisk? to create partitions. i made root and /home I was able to successfully install lxde and icewm. Everything was succesful. I am going to try to find a UEFI machine to test out and see how it does from the ISO.


#76

Thank you all! :slight_smile:
@scjet If you said ‘yes’ to copying the log to target it will be in /.m-a.log. But you will only be able to read it as root - I thought it would be a good idea in regards of data protection, but maybe that’s a bit overdone, I don’t know :wink:
Anyway, like it is currently you can open the file with a root filemanager, or with su in the terminal …


#77

Bare-Metal Install
GPT/UEFI/GRUB

So everything went fine except for a couple thnings.

1./
Under "Install Graphical … " -> "Install Display Driver"
Dialog screen showed the below:

__________________________________________
[]video-catalyst
[*]video-ati
[]video-vesa
[] xxxxxxx  # unrecognizable text ?
[]-------------------------------------------
[]NAME
[]-------------------------------------------
[]video-catalyst
[]video-ati
[]video-vesa
______________________________________________

Why is the above displayed repeatedly like that, as well as the “unrecognizable text” line. ?

2./
Under “Install Graphical Environment” , both the “Stable”, and “Development” Desktop iso profiles failed with:

“error: failed retrieving file manjaro-iso-profiles-base.17.xxxx …”

The “m-a.log” did not save the above error output from screen, however, the m-a.log did show the below, regarding failure retrieving the manjaro-iso-profiles-base.17.xxxx ?
from /.m-a.log:

...
02/28/17 12:34:07 setup_graphics_card video-ati 
02/28/17 12:34:32 update profiles pkgs
02/28/17 12:34:51 ERROR [Install needed pkg git.][1]  --inst_needed()<-install_manjaro_de_wm_git()
02/28/17 12:36:53 update profiles pkgs
02/28/17 12:39:44 update profiles pkgs
02/28/17 12:41:00 ERROR [Install needed pkg git.][1]  --inst_needed()<-install_manjaro_de_wm_git()
...

The above has been failing for about 3 hours now, [ignore the time in above output].

However, the other night, I had no problems retrieving, and installing above file.
Why is that iso-profiles file not syncing ? Has something changed in the latest manjaro-architect installer script ?

Anyway, I then went on, in the same Dialog screen, and installed an “Unconfigured Desktop environment” successfuly, which proves that my network, repo’s, … was all fine.


#78

hm, seems I broke install_needed function by trying to fix installing the pkg in question in any case - I’ll check that. sorry … :wink:


#79

well no. for me it’s working fine. what version of the architect does it say at the beginning of your log?


#80

no problem, and thanks for quick reply.


#81
:: manjaro-architect 0.7.4.r199.gbae1bfc-1 ::