[experimental] Manjaro-Architect Test-ISO



Hi @kb41, there’s a typo in the multimedia menu header., I’m correcting it right now.
Thank’s for spotting this! :thumbsup:


No problem


typo i spend 90% of my Linux time correcting Typos being dyslexic


:wink: In this case it was not an inherited upstream typo but my own original contribution … :blush:



Tried the installer and receive an error message for all chroot commands.
Just installed “base base-devel” and started having errors with bootloader.
Downloaded the install media today.


This looks familiar from an earlier version of the installer. Which version exactly have you been using? Latest version would be 0.7.4.r87.g4dd28a8
Also could you please check content of /var/log/m-a.log ?
Logging is still only marginal, but some hints might already be there :wink:


I downloaded the latest install media today and it downloads the latest version at startup.
Here is the content of the log you requested, VM is still running if you need something else.

02/20/17 22:31:41 UTC system: UEFI, init: systemd nw-client: nmtui
02/20/17 22:31:41 UTC select language
02/20/17 22:32:49 UTC mount /dev/sda2 as mkfs.ext4 -q.
02/20/17 22:34:48 UTC branch selected: testing
02/20/17 22:34:48 UTC rank mirrors
02/20/17 22:35:01 UTC edit pacman-mirrors.conf
02/20/17 22:35:16 UTC edit pacman.conf

Version of package:

Name            : manjaro-architect
Version         : 0.7.4.r87.g4dd28a8-1
Description     : Manjaro CLI net-installer, forked from the Archlinux Architect
Architecture    : any
URL             : https://github.com/Chrysostomus/manjaro-architect
Depends On      : bash  dialog  f2fs-tools  gptfdisk  manjaro-architect-launcher  manjaro-tools-base  mhwd  nilfs-utils  
Installed Size  : 525.00 KiB
Packager        : Bernhard Landauer <oberon@manjaro.org>
Build Date      : Mon 20 Feb 2017 05:10:13 PM UTC
Install Date    : Mon 20 Feb 2017 10:31:40 PM UTC


Just tried again with the Manjaro Architect. The install mulitmedia is working now. I was able to install muliple environments. This time I did cinnamon and awesome. I couldn’t quite figute awesome but it looked well awesome :sunglasses: I still haven’t done a bare metal install yet. I want to msake sure that I can do installs with no issue on my part first. So I’ll probably try a couple more before I get to that point. I appreciate your quick response in both threads. Keep up the good work to all involved


Downloaded the test iso.
Booted it in Vbox.
Logged in and started the setup program.

I installed UEFI+GRUB, BTRFS with minimal KDE profile. Everything worked out of the box.
Very well done. So many options and stuff to tweak, I can even installl packages not in the profile, at OS install time, which is very handy.

Thank you. Looking forward to a more trimmed down version.

Where’s the profile for this iso located btw? Maybe I’ll try and tweak some stuff myself. :slight_smile:
EDIT: Is it this one?:


That’s the profile, exactly, but I think we’re going to move it to manjaro/iso-profiles :slight_smile:


I finally got aorud to doing a bare metal install and it went well until I got to install the bootloader I got the following error:
[set PATH] [127] chroot: failed to run command 'PATH=/usr/loacl/sbin:/usr/local/bin:/usr/bin:/usr/bin/core-perl: No such file or directory. I went back to install base reinstalled but I still got the same error. I didn’t have this issue yesterday when I was installing in VMware


@Chrysostomus has corrected this error already, I just have to make a new package including the fix! Hang on a moment!


Ok I thought it fixed. I remember seeing something about it in the other thread. I though it it was fixed on the iso since it pulls form the internet. No worries


Please try again when you get updated to vb0.7.4.r117.g4f4ca6a.


Ok I started it up again unfortunately it won’t finish before I leave work. I’ll finish up tomorrow


Ok now I’m getting error after connecting to the internet error: target not found:manjaro-architect sudo: manjaro-architect: command not found


You have spelling errors.
It’s manjaro-architect, not manjaro-arhitect.


I didn’t use spell check :hushed:


What branch is enabled? manjaro-architect is only in unstable I think.


It won’t let me get that far it fails after downloading the package databases. It wasn’t doing this yesterday I was to get further along