[experimental] Manjaro-Architect Test-ISO

development
netinstall
manjaro-architect

#185

Okay, I can re-create

Looks to be the case.

Fish seemed to install during user creation, when I selected it as the default shell.

I’ll manjaro-chroot into this new system and have a look around.

$ sudo mount /dev/sdd1 /manjaro
$ sudo manjaro-chroot /manjaro

Fish was installed.

sh-4.4# pacman -Qi fish
Name            : fish
Version         : 2.5.0-1
Description     : Smart and user friendly shell intended mostly for interactive
                  use
Architecture    : x86_64
URL             : http://fishshell.com/
Licenses        : GPL2
Groups          : None
Provides        : None
Depends On      : bc  gcc-libs  inetutils  ncurses  which
Optional Deps   : python: for manual page completion parser and web configuration
                  tool [installed]
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 7.84 MiB
Packager        : Levente Polyak <anthraxx@archlinux.org>
Build Date      : Sat Feb 4 05:01:14 2017
Install Date    : Mon Mar 6 22:43:29 2017
Install Reason  : Explicitly installed
Install Script  : Yes
Validated By    : Signature
sh-4.4# chsh -l
/bin/sh
/bin/bash
/usr/bin/fish

#186

The installer sets path to shell wrong at user creation. It sets it to /bin/fish instead of /usr/bin/fish. Should be easy to fix


#187

Nicely done! Thanks for the help friend! ^×^


#188

Whenever in doubt, manjaro-chroot is your friend.

:slight_smile:

… and someone with the extensive knowledge of @Chrysostomus to quickly spot the error and supply the fix.

:wink:


#189

I thought that it would not be so picky about the path, because /bin is just a symlink to /usr/bin anyway, but apparently it doesn’t follow links.


#190

Changing shells in other m-a installed systems I think I remember seeing /usr/bin/zsh references also, but that was a while ago.

I’ll try the same unconfigured LxQt install with a zsh user and see if the same error occurs.


#191

zsh is referenced in both /bin/zsh and /usr/bin/zsh and works fine with latest fix.


#192

When you say “it”, do you mean the entry in /etc/shells, or is this path set elsewhere?

Current contents…

#
# /etc/shells
#

/bin/sh
/bin/bash

# End of file
/usr/bin/fish
/bin/zsh
/usr/bin/zsh

EDIT : Just edited this file with the correct fish shell path and now able to login.


#193

Was able to use the new iso to install a Cinnamon systemd desktop on a Dell e7440 with two hdds.


#194

Today I was trying to redo an old Thinkpad T410 with LXQt open-rc. Everything went fine until it came time to install grub I getthe following errors;
grub-instll --target=386-pc[1] Installing for i386-pc platform then when I hit ok I get this:
grub-mkconfig [1] /usr/bin/grub-probe: error : failed to get canonical path of 'overlay’
I manually partitioned the dirve using cfdisk and made a boot partition a root and /home. Also I did this BIOs and not Uefi


#195

Not withstanding other context here, you can’t do ‘grub-mkconfig’ (update-grub) from a livecd (liveboot) though you can do a ‘grub-install’.
You can do ‘grub-mkconfig’ (and grub-install) from a chroot though.
However, as systemd-nspawn chaims to be ‘chroot on steroids’, I tried (a few months ago) and ‘grub-mkconfig’ still won’t work in systemd-nspawn.

ps: “canonical path of ‘overlay’” ?
used to be "canonical path of ‘cow’.
Holy cow! Must be a catholic cow on a pilgrimage. :laughing:


#196

I thought that was strange as well.
Edit: I restarted Manjro-Architect and I didn’t manually partition the disk I just used the auto partition. I able to install LXQT full Openrc with an enlightment session


#197

Used manjaro-architect to install manjaro KDE into my USB thumb drive and it’s working great!

Thanks for the effort (:


#198

Hi ppl I was playing around with manjaro-architect and found that if one uses openrc and do unconfigured de with lxqt and sddm you get an error saying that it failed to add the service, xdm not found or something it says. When booting the system sddm and the gui does not start and the startx command also fails. All thought this doesn’t apply to the manjaro versions of lxqt, both stable and development. Which I find kind of weird and interesting. ^×^

I have tried this on both stable and unstable installs.


#199

It works fine with systemd.


#200

looks like displaymanager-openrc doesn’t get installed in the ‘unconfigured’ case.


#201

Thats missing in the root packages of at least the community packages don’t know about the manjaro ones.


#202

It’s not supposed to be in root packages since it will only be needed if you install a DM! :wink:
We need to add it at DM selection.


#203

If you make a community iso openrc it should boot with no changes? it won’t with that missing.


#204

We are not talking about community editions here. Those will need it in Packages-Desktop.