EW-7611ULB Not Detected


#1

Hello, I have Manjaro ARM, latest, for the Rockchip with an Edimax EW-7611ULB. The Edimax is a USB wifi adapter but it is not recognized by Manjaro. I have unplugged everything USB with only the adapter and it doesn’t work. I have tried the three different USB ports and it is not detected. I have looked on the forum and there does not appear to be anyone with this USB adapter. The Edimax tech support are a bunch of bozos and no help. I have searched AUR but there does not appear to be any EW7611 driver.

Is there any community member who knows about the Edimax EW-7611ULB that can help?


#2

Have you seen this: https://wikidevi.com/wiki/Edimax_EW-7611ULB

It says the chipset for that is an Realtek RTL8723BU - and there MAY be Linux drivers for that set. Check them out…


#3

If you have the rtl8723bu chip there are several drivers you can use I believe. I’m only on my cell so I can’t check in my package manager myself. If your search for 8723bu in your package manager you should find at least two drivers.

I belive there is now a driver for this chip in the Manjaro repobelieve There is also a driver in the AUR:

https://aur.archlinux.org/packages/rtl8723bu-git-dkms/

You must also install the linux-headers first with any dkms driver. Use this command to install the headers:

pamac install linux$(uname -r| grep -o -E '[0-9]+' | head -n 2 | sed 'N;s/\n//')-headers

#4

The AUR package that @tbg mentioned should work, but you need to install the headers package first, which is linux-rock64-headers for the Rock64.


#5

Yes, I saw from the Wikidevi site that it uses the RTL8723BU drivers. I also see that when I modprobe -a rtl8xxxu it loads, but I do not get any WIFI. In the network settings, or Wifi manager, there is no rtl8xxxu or rtl8723 device listed.

I am not able to install rtl8723bu-git-dkms or linux-headers because I do not have an internet connection.

The rtl8xxxu drivers/kernel modules seem to load without problem but, again, there is not any Wifi device listed or showing. I tried to search /dev for devices like wlan0 or wlan* but nothing comes up.

Does the rtl8xxxu driver not work with this chipset?

In the meantime I will try to figure out how to add rtl8723bu-git-dkms without internet access… T_T


#6

You could plug in a cable, just to get the AUR package installed.

What is the output of:
systemctl status NetworkManager.service


#7

Hello peoples. Thank you for some replies. I’m still not sure about the WIFI. Some threads on the forum say RTL8xxxu should work but it doesn’t seem to pickup any device or chipset for me after I load the module. Is RTL8xxxu kernel module not better than the AUR package?

I don’t currently have a ethernet cable long enough to reach this router. That’s part of why I’m looking to get WIFI working.

Below is the output from systemctl status NetworkManager.service (copied to/from USB drive):

● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
  Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
           └─NetworkManager-ovs.conf
   Active: active (running) since Mon 2019-02-11 18:51:46 CST; 15min ago
     Docs: man:NetworkManager(8)
 Main PID: 4684 (NetworkManager)
    Tasks: 3 (limit: 4749)
   Memory: 22.5M
   CGroup: /system.slice/NetworkManager.service
           └─4684 /usr/bin/NetworkManager --no-daemon

Feb 11 18:51:46 manjaro-arm NetworkManager[4684]: <info>  [1549932706.4575] manager: (dummy0): new Dummy device (/org/freedesktop/NetworkManager/Devices/2)
Feb 11 18:51:46 manjaro-arm NetworkManager[4684]: <info>  [1549932706.4756] manager: (eth0): new Ethernet device (/org/freedesktop/NetworkManager/Devices/3)
Feb 11 18:51:46 manjaro-arm NetworkManager[4684]: <info>  [1549932706.5067] keyfile: add connection /var/run/NetworkManager/system-connections/Wired connection 1.nmconnection (0b8fcd9a-f8a1-3de1-bb20-b6893067dcc4,"Wired connection 1")
Feb 11 18:51:46 manjaro-arm NetworkManager[4684]: <info>  [1549932706.5129] settings: (eth0): created default wired connection 'Wired connection 1'
Feb 11 18:51:46 manjaro-arm NetworkManager[4684]: <info>  [1549932706.5172] device (eth0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
Feb 11 18:51:46 manjaro-arm NetworkManager[4684]: <info>  [1549932706.5346] manager: (sit0): new IPTunnel device (/org/freedesktop/NetworkManager/Devices/4)
Feb 11 18:51:46 manjaro-arm NetworkManager[4684]: <info>  [1549932706.5638] ovsdb: Could not connect: No such file or directory
Feb 11 18:51:46 manjaro-arm NetworkManager[4684]: <info>  [1549932706.6066] bluez: use BlueZ version 5
Feb 11 18:51:52 manjaro-arm NetworkManager[4684]: <info>  [1549932712.5252] manager: startup complete
Feb 11 18:52:39 manjaro-arm NetworkManager[4684]: <info>  [1549932759.2776] agent-manager: req[0xaaaadcf833d0, :1.36/org.kde.plasma.networkmanagement/1000]: agent registered


#8

After you rmmod then modprobe the module you should try restarting network manager. It also doesn’t hurt to lower, then raise your adapter as well.

Are you trying to connect via a VPN?


#9

I issue systemctl restart NetworkManager.service after modprobe -a rtl8xxxu. It didn’t seem to do anything. I’m not sure how to lower or raise the adapter. It does not have a name that I am aware of. I am not trying to use or connect to a VPN.


#10

As this is an ARM device, it would be easy to just move the device closer to the router, connect the cable, install the stuff, and move it back afterwards.