Every Time I Boot Into Manjaro A Popup Is Shown To Enter Password For Encrypted Internal 4TB HDD?


Running Manjaro KDE fully updated on the Testing branch.

Every time I boot into Manjaro a popup is shown to enter password for encrypted internal 4TB HDD?
Manjaro was installed about 1 month ago on a brand new computer I built myself.

Manjaro is installed on a 2TB NVMe SSD.
The 4TB LUKS encrypted internal hard disk drive is used for personal files.

Does anyone know how to fix the above?


Your HDD is encrypted. What would you expect?


No offense, but you encrypt your personal data, but want to bypass the password prompt?



Yes, the hard disk drive is encrypted.
But why does it try to mount ever time I boot Manjaro?
My old computer did not do this with similar setup.


Because every time it gets mounted, it needs the passwordto decrypt it.

Similar but not exact. Different file system?

Probably some misunderstanding going on here …

What you probably mean/want to do is:

disable the automatic mount feature
that tries to mount and make available all the drives that are physically connected.

You can then still mount it when you need it.

But I can’t tell you how to do this in KDE since I do not use it and have not for quite some time.
Should not be difficult.


If this :point_up_2: is indeed the case, look here:

I believe what you’re looking for is an automount.

Hope this helps!

Ok, I setup the HDD not mounting on boot of Manjaro.
(I searched for “mount” in KDE System Settings)
Thank you for the help…

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.