Every application stopped working except firefox

yeah, nothing works and konsole is now “unknown application folder”. Going to reinstall everything

Executed commands from chroot. Output was fine. Rebooted to main system, nothing changed ;-;

damn, that was the ‘nuclear’ option…
post output from:
pacman -Qm
to check if you for what ever reason dont have some plasma packages from aur installed;
and also post output from:

cat /etc/mkinitcpio.conf
pacman-mirrors --get-branch
find /etc/X11/ -name "*.conf"
ls /etc/modprobe.d
manjaro-chroot -a                                                                              ✔ 
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sdb1.  Check your device.map.
==> Mounting (ManjaroLinux) [/dev/sda2]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
[manjaro /]# pacman -Qm
manjaro-documentation-en 20181009-1
manjaro-firmware 20160419-1
noto-fonts-compat 20151217-1
python-pep517 0.13.0-1
[manjaro /]# cat /etc/mkinitcpio.conf
# vim:set ft=sh
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)

# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries

# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.

# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS=(base)
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS=(base udev autodetect block filesystems)
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS=(base udev block filesystems)
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS=(base udev block mdadm encrypt filesystems)
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS=(base udev block lvm2 filesystems)
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS="base udev autodetect modconf block keyboard keymap consolefont filesystems fsck"

# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.

# Additional options for the compressor

# Decompress kernel modules during initramfs creation.
# Enable to speedup boot process, disable to save RAM
# during early userspace. Switch (yes/no).
[manjaro /]# pacman-mirrors --get-branch
[manjaro /]# find /etc/X11/ -name "*.conf"
[manjaro /]# ls /etc/modprobe.d
[manjaro /]# 

I may not have followed all of this.
But perhaps a different avenue.
Check your $PATH variable.
For both root and your user account.

echo $PATH

since everything seems to be in place - but nothing works …


You reminded me, that I made something with path when some standard python library wasn’t working. I guess that was “./local/bin” part

that $PATH is not exactly wrong - but it is decidedly different from what I have here:

echo $PATH

… make of that what you will/can :man_shrugging:

you can remove all of these:

pacman -R manjaro-documentation-en manjaro-firmware noto-fonts-compat python-pep517

they are not related to your issue, but those are dead packages, and you dont need them…

and i didnt see any configs related to video drivers, but you are having amd gpu, so maybe thats how it should be… but just to be sure, remove the drivers:
mhwd -r pci video-linux
install them:
mhwd -i pci video-linux

also install the latest 6.1 kernel:
pacman -S linux61
and remove these 2:
pacman -R linux419 linux510
you dont need that many kernels…

also post logs from 3 days ago, to see if there were also the machine check errors:
journalctl -b-3 -p4 --no-pager | grep mce

then create a new test user:

useradd --create-home testuser

and give it a password:

passwd testuser

reboot and select the new testuser and see if it has also issues…

and i have the same path as nachlese, so it could be related to your issue…

Okay, I guess that was PATH problem. I found lines I added. After I added these lines, I checked path and didn’t find any changes, so I thought there was no impact. But I just deleted that by chroot, everything works now!!! And I can even open terminal. Thanks everyone for your time! I appreciate that!

whow - ok :ok_hand:

it was just a hunch

keep it in mind for the future - the search path is … important

that was an unusual and new one, no?
I saw your efforts and just thought:
why not try this …

keep it up!
you are very knowledgeable, persistent and polite!
just matter of fact and to the point
I could (and should) learn from you.


1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.