ETPS/2 Touchpad Not Working - Kernel bug on Tigerlake?

I’ve just installed Manjaro on a new laptop, a Clevo NH77HJ and I’m having trouble getting the touchpad to work.
xinput list reports that its an ETPS/2 Elantech Touchpad and libinput shows that it is recognised with all the capabilities you would expect but running libinput debug-events and evtest shows that no events are being produced for this device.
So far I’ve tried:

  1. Adding i8042 options in grub - no effect
  2. Adding psmouse proto=imps in grub - this gets it working as a basic PS/2 mouse
  3. Creating a config file 30-touchpad.conf in /etc/X11/xorg.conf.d - no effect
  4. Installing the synaptics driver and modifying the 30 file to suit (getting desperate now) - no effect
  5. Installing the 5.12 kernel - now runs Wayland and xinput reports the touchpad as xwayland-relative-pointer:17 while libinput shows it as ETPS/2 Elantech Touchpad - but it still doesn’t work

Any advice on what else I could try would be gratefully received.
Is this a known bug? Lots of people seem to have similar problems.

1 Like

On examining dmesg I found this:
genirq: Failed to request resources for ELAN0412:01 (irq 140) on irqchip INT34C6:00
i2c_hid_acpi i2c-ELAN0412:01:Could not register for ELAN0412:01 interrupt, irq = 140, ret = -22
i2c_hid_acpi: probe of i2c-ELAN0412:01 failed with error -22
This Probably explains why it’s not working, it has no irq.
Anyone know what the error is and how I could fix it?

Here’s more detail from dmesg:

[ +0.016526] tigerlake-pinctrl INT34C6:00: pin 57 cannot be used as IRQ
[ +0.000012] genirq: Setting trigger mode 8 for irq 139 failed (intel_gpio_irq_type+0x0/0x140)
[ +0.004530] gpio gpiochip0: (INT34C6:00): gpiochip_lock_as_irq: cannot get GPIO direction
[ +0.002327] gpio gpiochip0: (INT34C6:00): unable to lock HW IRQ 44 for IRQ
[ +0.003088] genirq: Failed to request resources for ELAN0412:01 (irq 139) on irqchip INT34C6:00
[ +0.003814] i2c_hid_acpi i2c-ELAN0412:01: Could not register for ELAN0412:01 interrupt, irq = 139, ret = -22

So it looks like an inappropriate pin assignment for tigerlake. Is this a kernel bug?

This is the same issue bugzilla.kernel[dot]org/show_bug.cgi?id=213579
It’s maybe related to this bugzilla.kernel[dot]org/show_bug.cgi?id=199911 or this bugzilla.kernel[dot]org/show_bug.cgi?id=213463

IMHO it’s an issue related to the CPU intel 11800H

Note: I am using the [dot] because apparently I cannot post links (???)

Thanks patacca, 213579 looks to be exactly the same problem, the Clevo NH55HJ is the 15" screen version of my NH77HJ.
However, 213463 gives the impression that this kind of problem is firmware related so I may need a BIOS update to fix it.
I’ll keep an eye on it…

This bug has yielded a patch to the GPIO table to fix this problem. Any plans to add this patch to the Manjaro kernel?

any update?

The fix is in the latest 5.14 kernel.