Ethernet not working a Raspberry Pi 3B with any external drive attached

After I updated the system on my Raspberry Pi 3B I have no ethernet connection when i boot with external HDD or usb stick attached. When i boot it without HDD everything is ok.

I reisnstalled the system and there’s the same problem.

Here is journalctl -b -p err output when I boot it with an external drive:

Feb 04 01:22:11 manjaro-arm kernel: sd 0:0:0:0: [sda] Asking for cache data failed
Feb 04 01:22:11 manjaro-arm kernel: sd 0:0:0:0: [sda] Assuming drive cache: write through
Feb 04 01:22:12 manjaro-arm kernel: brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1
Feb 04 01:22:13 manjaro-arm kernel: brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43430-sdio for chip BCM43430/1
Feb 04 01:22:13 manjaro-arm kernel: brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM43430/1 wl0: Feb 16 2020 22:39:24 version (r724416 CY) FWID 01-bf41ed64

Rest assured ethernet has nothing to do with attached USB devices.

Remember that Raspi devices has always been meant for tinkering - and no hardware lasts for ever - especially cheap boards like the Pi and yes I too have an running v1B and several others to play with.

Especially overclocking will tear your hardware and then power consumption increase and makes other devices flaky.

It is more likely an issue with your power supply - or something attached drawing too much current - which collide with an update making you think it it is because of the update - when in fact it is not.

You power supply should be labelled 5v 2Ah / 2.5Ah - use a volt-meter and measure the current when you attach your stick or your disk.

1 Like

I have genuine Raspberry PSU.
When I attach USB HDD or USB stick after the boot, everything works as intended until the next reboot.

Which makes it even more possible it is power issue.

Did you overclock it? Overclocking is the fast track to get a flaky Pi.

No, i didn’t.

Do you boot from USB or SD?

Have you tried other USB devices?

How many USB devices?

There’s a lot of factors for power consumption and one USB stick may draw more power than another.

I didn’t know updates are still issued for RP3.

Only RP4 is officially supported - as far as I know.

I boot from SD.
When i boot with any other peripherials (without any external drive attached), keyboard, mouse, wireless keyboard+mouse everything is ok.

I can’t be 100% certain - but to my experience - any Pi really - are very solid.

There is only one way you flake them out - that is pulling more current than the PSU delivers. Especially disk devices can be a hit an miss - and due to the wear and tear - which is inevitable - on the electronics inside it will - over a long time - draw more power.

If you Pi works without the disk - and it have issues booting with the devices attached - the device is where to look - but I am no oracle and I cannot be 100% certain - but my experience and my gut-feeling tells me it is an issue with your USB device.

The RP3 has four USB ports - have you tried switching them around?

Another thought - it may not be your USB disk - it may be another USB device - like your mouse or your keyboard?

One or the other won’t make a problem - but when together …

There’s a lot of combinations to be tested …

I also thought about it, but i dont think that 16GB usb stick consumes more energy than keyboard and mouse attached.
Also I noticed that I cannot execute any command as superuser when i boot with external drive attached.

RP3 can boot from USB - but you have to make a change to the SoC - have you ever changed the firmware to look for USB when booting?

Is your USB device bootable in any way - I have had funny errors with other ARM devices if an USB - bootable on x86 - is attach to the ARM device when booting - yes I know ARM doesn’t boot x86 but anyway - I have had some annoying experiences - which disappeared when removing the GRUB/MBR formatted device.

As i said before when trying to solve the problem i flashed Manjaro-ARM-xfce-rpi4-21.02.img - the same problem on fresh install.

Maybe there’s a way to get older images?

I am not at all sure the RP4 image works on RP3 - in fact I am in the process of testing - if it works.

Be aware, that some USB drives generate interference, that can block other things.

Also, on the Raspberry Pi 3, the ethernet and the USB ports are actually using the same bus, so that might conflict a bit too.

1 Like

It worked pretty stable for a half of the year.

The problem has gone after downgrade of the following packages:

 [2021-03-18T19:08:58+0300] [ALPM] downgraded linux-rpi4-headers (5.10.17-1 -> 5.4.83-1)
 [2021-03-18T19:07:19+0300] [ALPM] downgraded linux-rpi4 (5.10.17-1 -> 5.4.83-1)