Ethernet is really slow and randomly disconnects in multiple kernels

I have searched info everywhere and i dont find any that neither applies nor works, i will post any result of the commands you tell me to use

how to request help, there is some links there to help you supply info to help you. [HowTo] Request support

there is nothing specific to my issue, but here you have ip addr result (i think it seems ok):

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host noprefixroute
valid_lft forever preferred_lft forever
2: enp5s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
link/ether 22:09:5c:05:08:eb brd ff:ff:ff:ff:ff:ff
inet 192.168.0.21/16 brd 192.168.255.255 scope global dynamic noprefixroute enp5s0
valid_lft 85988sec preferred_lft 85988sec
inet6 fe80::2009:5cff:fe05:8eb/64 scope link
valid_lft forever preferred_lft forever

can you return

inxi -MEJnxxx

yeah, here you have it

Machine:
Type: Desktop Mobo: INTEL model: E5-H9 v: V1.1 serial:
uuid: UEFI-[Legacy]: American Megatrends v: 5.11
date: 11/16/2022
Network:
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: d000
bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: 22:09:5c:05:08:eb
Bluetooth:
Message: No bluetooth data found.
USB:
Hub-1: 1-0:1 info: full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
lanes: 1 chip-ID: 1d6b:0002 class-ID: 0900
Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
speed: 480 Mb/s lanes: 1 chip-ID: 8087:8008 class-ID: 0900
Hub-3: 2-0:1 info: full speed or root hub ports: 2 rev: 2.0
speed: 480 Mb/s lanes: 1 chip-ID: 1d6b:0002 class-ID: 0900
Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
speed: 480 Mb/s lanes: 1 chip-ID: 8087:8000 class-ID: 0900
Hub-5: 3-0:1 info: hi-speed hub with single TT ports: 12 rev: 2.0
speed: 480 Mb/s lanes: 1 chip-ID: 1d6b:0002 class-ID: 0900
Device-1: 3-6:2 info: C-Media USB Audio Device type: audio,HID
driver: hid-generic,snd-usb-audio,usbhid interfaces: 4 rev: 1.1
speed: 12 Mb/s lanes: 1 power: 100mA chip-ID: 0d8c:0012 class-ID: 0300
Device-2: 3-7:3 info: Holtek Gaming Mouse [Redragon M908]
type: mouse,keyboard,HID driver: hid-generic,usbhid interfaces: 3 rev: 2.0
speed: 12 Mb/s lanes: 1 power: 100mA chip-ID: 04d9:fc4d class-ID: 0300
Device-3: 3-8:4 info: Microdia USB DEVICE type: keyboard,mouse
driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s lanes: 1
power: 400mA chip-ID: 0c45:672e class-ID: 0301
Hub-6: 4-0:1 info: super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
lanes: 1 chip-ID: 1d6b:0003 class-ID: 0900

can you report

sudo mhwd-kernel -li
sudo journalctl -b0 | grep 'r816'

The following kernels are installed in your system:
* linux515

I used mhwd-kernel with rmc to change kernels, also tried 6.6 and 6.5

jun 01 12:30:53 manjaro kernel: r8169 0000:05:00.0: can’t disable ASPM; OS doesn’t have ASPM control
jun 01 12:30:53 manjaro kernel: r8169 0000:05:00.0 eth0: RTL8168gu/8111gu, 22:09:5c:05:08:eb, XID 509, IRQ 42
jun 01 12:30:53 manjaro kernel: r8169 0000:05:00.0 eth0: jumbo features [frames: 9194 bytes, tx checksumming: ko]
jun 01 12:30:53 manjaro kernel: r8169 0000:05:00.0 enp5s0: renamed from eth0
jun 01 12:30:54 manjaro kernel: Generic FE-GE Realtek PHY r8169-0-500:00: attached PHY driver (mii_bus:phy_addr=r8169-0-500:00, irq=MAC)
jun 01 12:30:55 manjaro kernel: r8169 0000:05:00.0 enp5s0: Link is Down
jun 01 12:30:57 manjaro kernel: r8169 0000:05:00.0 enp5s0: Link is Up - 1Gbps/Full - flow control rx/tx

hour is wrong by 2 hours, it seems graaphical interface settings cant change that

If your time differs from the rest of the world (Internet), that can cause problems.
I only know timedatectl to change it.

Or the normal during install, NTP and use UTC, correct timezone.

I have RTL 8168, have used it for 6 years or so. Manjaro has never had a problem with it. Other distros, sure, Fedora, OpenMandriva. Those are the only distros that I have issues with. Internet works for 1-2 secs every 5 minutes.

I am a distrohopper so I have tested tons over the years, probably 50-100 different distro versions and distros.

already changed hour, doesnt change, one thing i noticed is that if im the only one using internet it has normal speed, but i dont know how to give priority to my pc

Try using the r8168 driver instead of r8169 driver

sudo mhwd -i pci network-r8168

I have an old Asus motherboard with an old version of this NIC that had similar issues when using r8169 driver and some kernel versions

Please clarify this.

Are you saying you only notice this really slow Internet when other users are sharing your connection/bandwidth? If this is the case, it has nothing to do with Manjaro.

You may need instead to allocate greater bandwidth to your machine; or, give priority to your pc - that thing you apparently don’t know how to do, yet know enough to describe it.

Check your router settings, and look for Quality of Service (QoS)

If you perform a quick Internet search you will find more instructions on how to do this than you will know what to do with. Here are just a few:

You will likely need to narrow your search to produce results for your particular router.

Cheers.

Have you tried using a different ethernet cable?

in general it is slower, but somehow when saring network, sometimes fully fails, but it is slow in general, i tried to search for the QoS on my router web server, but nothing

i know tre cables cant be because on upload it is as fast as it should

Is it the same with WLAN?

no, phones have nice speed, cant test with the PC because i didnt get a wifi network card

Have you tried using ethernet with any other device on the same network?

yes, and it works, also this pc had windows, and it worked fine, after manjaro instalation it didnt work as well

1 Like

Then I think it’s most likely a driver issue or a configuration of the OS. Especially if you are using older hardware.

Perhaps you needed to spend more than three minutes searching.

The manual for your router should have the information you need. If you don’t have the manual, it will be available online if you search for it by brand and model number.