Ethernet connection to router fails to set network address

Ever since the last major update a while ago, I have been unable to make a connection via Ethernet to my broad band router. When I look from the network panel on my desktop (Plasma) I see it attempts to set network address (to get one for itself from the router for the internal network?) and after a 5 seconds or so, it cuts the connection and starts a new attempt.

First problem I had after the update was that my Realtek Ethernet adapter’s driver had vanished so I had to reinstall it. Connecting through USB via my phone works fine. On the Windows side of the dual boot, there are no problems. Some times the Ethernet connection starts working either in a limited capacity up to the router but not further, in a full capacity but slow speed, or even in a regular manner. Seems to consistently happen around 1h 30min uptime mark, not always though. Switching kernels does not solve the issue.

Oh, and it’s a pretty old Inteno router (around 7 years), I can check the exact model when I get home if some one needs that. I’m out of ideas and would be happy for assistance.

2 Likes

That sounds a lot like an auto-negotiation issue. Windows has some built-in functionality to “automagically” “fix” network speeds, which Linux does not have. In 95% of the times this is due to dodgy cabling and in 5% of the time it’s a combination of router and PC NIC firmware so:

  1. Change your Ethernet cable with a new one
    1.1. No, Really: change the cable first!
    1.2. Even though you don’t belive me, change the cable anyway. :innocent:
  2. If that didn’t solve the issue, try another port on your router
  3. If that didn’t fix the issue, and you can set the router port speed:
    3.1. start by setting the router port speed to 10 Mbps half duplex and if that works:
    3.2. 10 Mbps full duplex, 100 Mbps half duplex and so on until it stops working!
    3.3. Go down one notch to the last working speed.
  4. If you cannot set the router port speed, do it on your PC:
    4.1. mcli connection modify eth0 802-3-ethernet.auto-negotiate no 802-3-ethernet.speed x 802-3-ethernet.duplex y where:
    • eth0 is the name of your NIC
    • x = 10, 100 or 1000
    • y = half or full

(And obviously stop when it stops working and then go down one notch)

Feed back with your findings if that would go wrong somewhere

:innocent:

Well I’ll be damned! Got a new cable, replaced the old one and everything works again.

Thank you very much. I’ll keep this in mind for the future.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.