ESXi in a KVM virtual machine - install error "No network adapters"

I am trying to install esxi7 inside a KVM machine

    virt-install --name=esxi7 \
    --vcpus=2 \
    --memory=4096 \
    --cdrom=/home/username/isos/VMware-VMvisor-Installer-7.0U2a-17867351.x86_64.iso \
    --disk size=33 \

the installation process starts but does not get fails with a “No network adapters” error. This does not happen with other VM’s.
What do I have to add to above command in order to attach the default network adapter to the machine?

or is there any other trick I have to be aware of when it comes to installing ESXi?

Where VMware workstation and VirtualBox is running on top of another system - esxi is a bare-metal hypervisor - it runs on physical hardware - like Xen which is also a bare-metal hypervisor.

It makes no sense to run a bare-metal hypervisor inside a virtual machine.

QubesOS is a great example of an OS which runs on top of the Xen bare-metal hypervisor.

1 Like

I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

it does if you want to study that particular hypervisor.

I am aware of all that. And I need to get familiar with ESXi without haveing spare bare metal HW available. The question is whether, and how it is possible to run inside a KVM Machine. And I believe it should be possible

  • Yes, it’s possible
  • No, it’s not supported by VMWare
  • No, it’s unworkably slow

Source: I used to work for a Cloud Service Provider, and tried doing the same as you, managed to get it working on Oracle’s VirtualBox on a beefy laptop with 24G of RAM and then threw it out after an entire day of work setting it up and ended up installing it on an old clunker of a laptop with 8GB RAM that was lying around because it was so unworkably slow.


P.S. Not going to reset the solution to @linux-aarhus answer because you took it away, but basically, you’re on your own! No one in their right mind tries doing that! :sob:

I have been using esxi as well - had it running for years on a T61p laptop with 8G RAM and ssd. I can tell you running esxi in a virtual machine is unsupported.

I believe I can fly … and I can … the worst thing is the landing.

I you think it is possible - why haven’t you searched the internet for the way to do it?

In addition to the subject - you need to know the difference between hypervisors type-1 and type-2.

  • Type-1 runs on bare-metal - esxi is a type-1 hypervisor
  • Type-2 requires an operating system to function - VirtualBox is type-2 hypervisor.

I am quite sure lot of people have tried to stack type-1 hypervisors - but the end result will - just as @Fabby noted - not be worth the effort because type-1 hypervisors are substantially different than type-2.

1 Like

so what is the way to study ESXi (or any other type1 HV) then?

That’s the way:

Get your company to give you an old clunker of a laptop with 8GB of RAM for studying ESXI or if a private person, ask around at your friends if they have a few old clunkers lying around and combine all the old clunkers into one PC with 8GB of RAM.

Alternatively (I’ve never tried doing this!) You could install rEFInd which is a Boot Manager, not a Boot Loader and install ESXi in dual boot on the system you’re writing this on…

sorry, I over read that