Error: you need to load the kernel first

error: file ‘/boot/vmlinuz-4.4-x86_64’ not found.
error: you need to load the kernel first

Pacman upgrade was fine, no errors… Then I reboot and now I’m stuck with this error. None of my kernels work. Now I wish I had not upgraded. I assume I need a new kernel?

I’m thinking maybe the solution is to boot a new Manjaro off USB and try to install from the USB to the laptop?

I have the live USB booted, now I’m not sure how to add a new kernel to the laptop (without starting from scratch.)

Well the XFCE image comes with an Architect option, which is nice… Architect has an option to “rescue” so I’m trying that now… I was able to chroot my cryptoluks drive and I’m installing linux-lts right now… fingers crossed. Also I think it updated my grub as well.

OK that solved it. Architect saved the day. Trying to mount the cryptoluks drive the hard way was going to be a nightmare. Architect mounted the drive easily… Summary of the steps I took:

  1. Boot LIVE USB XFCE and launch Architect, or I suppose you could boot Architect by itself.
  2. Mount the laptop’s disk in Architect. I wasn’t sure which partition had grub, but it probably wasn’t “swap” so I just chose the largest one.
  3. Under “Rescue” there is an option to upgrade grub, and I chose the “os prober” option (not sure if that was necessary or not.)
  4. In Architect there’s a chroot option. Once in, I did ‘pacman -Ss kernel lts’ and chose to install the first one, I think it was “kernel-lts”
  5. exit the chroot… then Architect went into some weird infinite loop (definitely a bug in Architect, but whatever…)
  6. Shut down the live USB.
  7. Rebooted to a new grub screen that looks very nice.
  8. Everything booted correctly, as expected.

In conclusion, was the problem an old kernel, or an old grub, or both? I don’t know…


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.