Error with glibc while installing nix

I was trying to install nix according to the steps given at NixOS - Nix 2.3.12 manual.
The installation steps are successful, but when I tried running nix-shell -p nix-info --run "nix-info -m" just to verify the installation, there was nix-shell: symbol lookup error: /usr/lib/ undefined symbol: _dl_fatal_printf, version GLIBC_PRIVATE.
Apparently this has to do with glibc, which doesn’t have an intended symbol. I tried re-installing glibc, tried other nix installation methods, but the error went the same.
I wonder if this is because of some version incompatibility? My glibc version is glibc-2.33-5.

我按照nix官网上的流程尝试安装nix,安装过程顺利,但是在安装完执行nix-shell -p nix-info --run "nix-info -m"验证的时候显示nix-shell: symbol lookup error: /usr/lib/ undefined symbol: _dl_fatal_printf, version GLIBC_PRIVATE。我重装了glibc,改为单用户安装nix,报错都一样。

As nix is an AUR package, I would first advise you to rebuild it, or if you are not yet, actually use the AUR package.

Well… I actually didn’t use the AUR package but the installation script provided on their website at first :frowning:
Anyway I’ll try it now, thanks so much!

Yeah, and their “binary” seems to be compiled against an older version of glibc.

1 Like

Following the Archwiki page I finally managed to install nix… But that page is marked deprecated and there are problems with nixpkgs :frowning: .
I have decided to use qemu with a minimal NixOS ISO file to explore nix instead of wasting my time on a foreign package with deprecated wiki page.
Anyway this did solve the glibc problem, thanks a lot for that!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.