Error while updating system

When I try to run

sudo pacman -Syu

I receive the message:

error: failed to commit transaction (conflicting files)
plasma-desktop: /usr/bin/knetattach exists in filesystem (owned by knetattach)
plasma-desktop: /usr/share/applications/org.kde.knetattach.desktop exists in filesystem (owned by knetattach)
Errors occurred, no packages were upgraded.

This is probably an normal problem, but I couldn’t solve it with the solutions that I found online
I’m new to manjaro

Try now:

sudo mv /usr/share/applications/org.kde.knetattach.desktop /usr/share/applications/org.kde.knetattach.backup
sudo pacman -Syyu --overwrite /usr/share/applications/org.kde.knetattach.desktop

Also just to add, I think pamac automatically solves these kind of issues.

No success :frowning: When I try the first command I receive this:

mv: cannot stat '/usr/share/applications/org.kde.knetattach.desktop': No such file or directory

I also tried to run sudo pamac update and got this:

Error: Failed to commit transaction:
conflicting files:
- plasma-desktop: /usr/bin/knetattach already exists in filesystem (owned by knetattach)

Doing some research shows that knetattach is a part of plasma-desktop so you can remove that package and carry on with the update.

sudo pacman -Rs knetattach
sudo pacman -Syyu

Thank you! The first command I had to use -Rdd instead of -Rs, but it worked just fine!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.