Error while creating partition table while installing manjaro

I’m trying to install manjaro but when I click install I get an error saying ‘the installer failed to create a partition table on (hard drive name.') Iv tried creating the partition table using KDE partition editor but just get the same error. I also don’t think it’s a faulty hard drive as it’s only a few months old. I also tried reformatting the hdd and got some read/write errors. Iv installed Manjaro before and it went fine. could someone please help me out with this, thanks.

Did the message perhaps also say that it could not do what you wanted it to do
because the drive was already mounted?

Make sure the drive is not mounted, unmount it if it is.

so i just realized that when i try and install manjaro, my hard drive partitions disappear and it tells me theres no partition table and i have to physically unplug and plug the hard drive in again for them to show up. im unsure if its mounted or not.

Well … if you can access the contents of the drive/partition … it is mounted.

You should be able to use whatever file manager you have
to unmount them.

it wants to create partition table - MBR, GPT, so if you are running in bios mode and you booted in uefi mode it want to create a GPT which is not supported in bios mode …
also is fast startup disabled in windows
is secure boot disabled in bios
is AHCI enabled in bios

yes to all, i am running in uefi mode, i dont have windows so fast startup isnt enabled

are you using btrfs?
run fsck on the drive
Navigate to System Settings → Removable Storage → Removable Devices and uncheck under All known devices the following: On Login and On Attach.
Then ensure the device is unmounted - in a terminal run the following command - and the MOUNTPOINTS column should be empty:
lsblk -f

iv unchecked them but the mount points arnt empty

post the output from the lsblk command

edit your post, use formatting, click this icon in editor: </> and copy the output there

NAME  FSTYPE FSVER LABEL           UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0 squash 4.0                                                              0   100% /run/miso/sfs/livefs
loop1 squash 4.0                                                              0   100% /run/miso/sfs/mhwdfs
loop2 squash 4.0                                                              0   100% /run/miso/sfs/desktopfs
loop3 squash 4.0                                                              0   100% /run/miso/sfs/rootfs
sda                                                                                    
sdb   iso966 Jolie MANJARO_KDE_2137
                                   2022-08-16-12-52-10-00                     0   100% /run/miso/bootmnt
├─sdb1
│     iso966 Jolie MANJARO_KDE_2137
│                                  2022-08-16-12-52-10-00                              
└─sdb2
      vfat   FAT12 MISO_EFI        C80E-8B3F                                           

so the sda is unmounted, first run fsck on it:
sudo fsck -f /dev/sda

fsck from util-linux 2.38.1
e2fsck 1.46.5 (30-Dec-2021)
ext2fs_open2: Bad magic number in super-block
fsck.ext2: Superblock invalid, trying backup blocks...
fsck.ext2: Bad magic number in super-block while trying to open /dev/sda

The superblock could not be read or does not describe a valid ext2/ext3/ext4
filesystem.  If the device is valid and it really contains an ext2/ext3/ext4
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>
 or
    e2fsck -b 32768 <device>

/dev/sda contains `DOS/MBR boot sector; partition 1 : ID=0xee, start-CHS (0x0,0,2), end-CHS (0x3ff,255,63), startsector 1, 3907029167 sectors, extended partition table (last)' data

ok so the drive is not formatted … and also it is a MBR …try running the install now

it got past the partition table part, now it says

Create a new partition (300.00 MiB, fat32) on ‘/dev/sda’


Job: Create new partition on device ‘/dev/sda’


Command: sfdisk --force --append /dev/sda

Failed to add partition ‘New Partition’ to device ‘/dev/sda’.

Failed to add partition ‘New Partition’ to device ‘/dev/sda’.

is this the latest iso ?

should be, ill try reinstalling it and see if it helps.

still getting the same error with a fresh install

run this:
sudo calamares -d

same error again