error when updating, dependency issue?

I receive this error when I try to update everything:

could not satisfy dependencies:
installing x265 (3.1.2-1) breaks dependency '' required by ffmpeg2.8

This one is new to me. Can anyone advise? Thanks!

You can't upgrade because ffmpeg2.8 needed an outdated version of x265 but we want to update it instead so pacman can't update these.

This could be easily solved if ffmpeg2.8 were provided and updated in repository. But it's not, it's an AUR package. I suggest to either ditch ffmpeg2.8 and use ffmpeg provided by repo, or rebuild ffmpeg2.8 against new version of x265

ffmpeg was at one point something you needed .. but it got relegated to the AUR and should not be required by normal packages.

I suppose if you are just experiencing this, its probably not the same evolution path .. maybe rather from a package you installed at some point.

Maybe check"

pacman -Qi ffmpeg2.8

to see if/what depends on it.

Name            : ffmpeg2.8
Version         : 2.8.15-2
Description     : Complete solution to record, convert and stream audio and
Architecture    : x86_64
URL             :
Licenses        : GPL3
Groups          : None
Provides        :
Depends On      : alsa-lib  bzip2  fontconfig  fribidi  glibc  gmp  gnutls  gsm
                  jack  lame  libmodplug  libpulse  libsoxr  libssh  libtheora
                  libvdpau  libwebp  libx11  libxcb  libxext  libxv
                  opencore-amr  openjpeg  opus  schroedinger  sdl  speex
                  v4l-utils  xz  zlib
Optional Deps   : ladspa: LADSPA filters [installed]
Required By     : bomi
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 17.36 MiB
Packager        : Unknown Packager
Build Date      : Fri 21 Jun 2019 04:55:56 PM EDT
Install Date    : Fri 21 Jun 2019 05:19:42 PM EDT
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : None

This is what I have. I also looked in my installed programs for it, but it didn't show up so I couldn't install it.

1 Like

Weird, I took another crack at finding it, it showed up this time, and then removed it. Things appear to be working normal now. Thanks for the assist!

1 Like

Could you explain this solution? I'm confused.

1 Like

ffmpeg2.8 is the problem.
If you need it then you have to wait or wrestle with it and its dependencies.
[even then the maintainer seems to do a piss poor job of ... maintaining it and not making it a huge issue to deal with.]
In this case OP had it because bomi depends on it.
Apparently that wasnt a big deal and they just removed ffmpeg2.8 (and I assume bomi too)
Then everything was roses.

[ffmpeg2.8 is in the AUR and has a right proper muddlefrick of dependencies and weirdness. It should be avoided at almost all costs. Some need it .. but if you dont .. just forget about it and its problems]



and @Sinister solution would have worked as well.

... and this merited a self solve :face_with_monocle: That is what confuses me.

To be fair, ffmpeg2.8 was also actually an official arch package long time ago.
Depending on the age of the system though, it may not get automatically fixed anymore.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by