Error when trying to complete updates via Add Remove Software application

conflicting files:

  • plasma-workspace: /usr/share/locale/ta/LC_MESSAGES/ already exists in filesystem (owned by plasma-desktop-primex)

When i try to do updates, i get the above error. Any advice?

You are using the testing branch of Manajaro.

Check the last thread of your branch update: [Testing Update] 2021-05-12 - Kernels, KDE Frameworks, Plasma, Systemd, Mesa, LibreOffice, KDE Gear Mobile, FF, TB - #13 by Mathew-D

There you will find a solution proposed by user Mathew-D, who apparently has the same problem.

Or best not use plasma-desktop-primex

I have this same error with the latest updates via pamac. I a NOT using the testing branch, and have no idea what plasma-desktop-primex is. Any suggestions on how to proceed and how to prevent this?

From System Info:

Operating System: Manjaro Linux
KDE Plasma Version: 5.21.4
KDE Frameworks Version: 5.81.0
Qt Version: 5.15.2
Kernel Version: 5.10.34-1-MANJARO
OS Type: 64-bit
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 2700X Eight-Core Processor
Memory: 31.3 GiB of RAM
Graphics Processor: Radeon RX 580 Series


Same as buzzra, here.
Also, replacing plasma-desktop-primex package with plasma-desktop did enable the update to take place, but then the desktop was broken.
(Thanks god I had timeshift-autosnap and grub-btrfs installed :smile: so I didn´t have to reinstall the whole system again.)

Can someone explain how I’ve got this testing update when I never installed unstable versions of Manjaro? I have this system for almost a year and it went well, and now I receive such an issue.

I also had the same problem. Like buzzra above, I am not on testing branch and have no idea what plasma-desktop-primex is ( vs regular plasma-desktop?). Like in the other post referenced above, I did

sudo mv /usr/share/locale/ta/LC_MESSAGES/ /usr/share/locale/ta/LC_MESSAGES/

which seems to have worked.


Thank you for the solution it worked like a charm

I did not follow these steps to create a backup of autostart file, but followed with instaling the update which removed some nvidia package and now I cannot boot to my desktop!

In TTY2, I have executed plasmashell to get

qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem

I have tried all of the following, with no luck:

sudo pacman -S mhwd-db
sudo pacman -S nvidia-utils

sudo pacman -Syu plasma-desktop
sudo pacman -Syyu libxcb lib32-libxcb qt5-base

I really don’t remember the exact name of the package being removed and I need my PC to work!

No timeshift backup either :frowning:

Thanks, fixed my issue. Should have known to just to rename it and let it try again. Good to have a reminder.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.