Error when mounting raid

I recently tried to install manjaro on a raid with architect. I could configure the raid, failed when mounting. I tested it in virtualbox.


Yeah it can’t be found because it has other names:

ls /dev/md*
/dev/md126  /dev/md127

boot  root

Seems to be an easy bug, but don’t know if it reported already.


Seems to be something wrong on this line:

Thank you for reporting. @cscs do you want to take a look at this?

1 Like

I am not super familiar with raid.
Have its functions changed in recent versions ?
That is - is the /dev/md/${i} deprecated in favor of /dev/${i} ?
or do we need to make provisions for both cases ?

To be more precise:

When i setup the raid, then i typed the name boot for the first partition /dev/md127 and root for the second partition /dev/md126. The names don’t get recognized. if i write nothing, same problem also. Not able to mount. But if i write the name md127 for /dev/md127 and md126 for /dev/md126, then it worked.

The script can’t detect the current names.

I would solve it myself but i am not familiar with awk.