Error when forcing resolution in Manjaro Gnome

Hey guys. I’m using 2 monitors, my PC only has one HDMI input. On the second monitor, I’m using VGA. I want to force a 1920x1080 resolution on the VGA monitor, but this error occurs.

I’m trying to create a new resolution using xrandr.

  Screen 0: minimum 16 x 16, current 2944 x 1080, maximum 32767 x 32767
XWAYLAND0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 530mm x 300mm
   1920x1080     59.96*+
   1440x1080     59.99  
   1400x1050     59.98  
   1280x1024     59.89  
   1280x960      59.94  
   1152x864      59.96  
   1024x768      59.92  
   800x600       59.86  
   640x480       59.38  
   320x240       59.52  
   1680x1050     59.95  
   1440x900      59.89  
   1280x800      59.81  
   720x480       59.71  
   640x400       59.95  
   320x200       58.96  
   1600x900      59.95  
   1368x768      59.88  
   1280x720      59.86  
   1024x576      59.90  
   864x486       59.92  
   720x400       59.55  
   640x350       59.77  
XWAYLAND1 connected 1024x768+1920+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768      59.92*+
   800x600       59.86  
   640x480       59.38  
   320x240       59.52  
   720x480       59.71  
   640x400       59.95  
   320x200       58.96  
   1024x576      59.90  
   864x486       59.92  
   720x400       59.55  
   640x350       59.77  
    ~  cvt  1920 1080 60                                                ✔ 
# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
    ~  xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync 
    ~  xrandr --addmode XWAYLAND1 1920x1080_60.00                       ✔ 
    ~  xrandr --output XWAYLAND1 --mode 1920x1080_60.00

But the error below occurs:

X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  21 (RRSetCrtcConfig)
  Value in failed request:  0x780
  Serial number of failed request:  29
  Current serial number in output stream:  29

What’s the make and model of the VGA monitor? Are you sure it supports 1920x1080 via VGA?

The monitor is from LG. Yes, that resolution is supportable on it. These commands that I put in the topic, work normally on Ubuntu-based distros. Does not work on Manjaro and Fedora.

is already “the same” as 1920x1080_60.00 so why forcing it?

Because in my case, any Linux distro doesn’t recognize the 1920x1080 of the VGA. I need to add it manually.

But what is the

and

doing there? You should have some like VGA1 and HDMI1, or something like that in the connector field. So you then can add it like

xrandr --addmode VGA1 1920x1080_60.00

and then

xrandr --output VGA1 --mode 1920x1080_60.00

If you run under wayland session the xrandr will not work.
https://wiki.archlinux.org/title/xrandr#Adding_undetected_resolutions

So Manjaro recognizes my VGA-1 as XWAYLAND-1. On Ubuntu based distros it recognizes it as VGA-1 and adding the resolution works normally. But in Manjaro this problem occurs.

Ok, but Xwayland = an X server for running X clients under Wayland. So, you are not under X11 session. You can check from terminal with:

echo $XDG_SESSION_TYPE

Better try either this

or check this
http://aur.archlinux.org/packages/wlr-randr

I managed to solve it, thanks!

Maybe share what you did, so others benefit from it, and mark that as solution if none of the above comments was pointing you to the actual solution …

The problem was that Manjaro uses the Wayland window system. Switching to x11, the problem was solved.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.