Error symbol 'grub_key_is_interrupt' not found

Hi,

But Have GPT / EFI boot.
Have push update for make my grub in quiet but now have this error !

Error symbol 'grub_key_is_interrupt' not found

Cordialy

GRUB_DEFAULT=saved
GRUB_TIMEOUT=2
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=9279d029-76ea-4934-a11c-6841ebc97cc3 loglevel=3 vga=current rd.systemd.show_status=auto rd.udev.log-priority=3 vt.global_cursor_default=0"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=5
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter 
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx" 
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

You need to repair your Grub.

See the following tutorial can help you: Using livecd v17.0.1 as grub to boot OS with broken bootloader

Use the version of manjaro that you have, or take the last one.

Ok is fixed but a see systemd log for what ?

not grub see the logo have systemd logs

check and update after 30 sec if boot ( kernel & system version is ok ) for next boot
if false , take version before

OK, what exactly was done. grub_key_is_interrupt got introduced with this patch and therefore got added with grub 2.03.0-10. Does a standard Manjaro v18.0 ISO release work?

You have to create your Live media properly.
Use only:

  • dd command as wiki
sudo dd bs=4M if=<manjaro-path-filename>.iso of=/dev/sd<a,b etc> status=progress
  • Etcher
  • Suse USB media creator
  • Rufus, in DD mode ONLY!!!
1 Like

This happens to me when using a (now out of date) 18.0rc3 installer. Is this fixed if I update and reinstall grub?

Do you mean you have it installed! If yes, an update is the 1st thing to do. If not, I suggest you download the latest ISO.

I had it installed. I had to reinstall grub to fix the issue

1 Like

“Rufus, in DD mode ONLY!!!”
THIS saved me. I just wanted to install Manjaro KDE on my laptop and wipe KDE neon out. Thx a lot ! :slight_smile:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.