Error resume: no device specified for hibernation

So a friend helped me install manjaro linux on my Dell laptop 8GB ram, Dual Boot with windows and Refind for bootloader.
Everything works fine except that i cannot resume my applications after hibernate on manjaro. It just boots normally, when i start it after i hibernate it. Since i chose to install manjaro in my hdd and not ssd my boot times are not what i'm used to. so i wanted to get hibernate working.

Although my friend made a swap partition 8GB, I get an error every time I boot into Manjaro:
"Error: resume: no device specified for hibernation"
my swap partition is sda3 and root is in sda5

Please post the output of the following commands:

sudo blkid -o list
cat /etc/fstab
cat /etc/default/grub | grep GRUB_CMDLINE_LINUX_DEFAULT
cat /etc/mkinitcpio.conf | grep HOOKS

For better readability, highlight the pasted output text and click the </> button to format.

1 Like

sudo blkid -o list

device     fs_type label    mount point    UUID
-------------------------------------------------------------------------------
/dev/sda1                   (not mounted)  
/dev/sda2  ntfs    DATA     (not mounted)  1256181A561800E1
/dev/sda3  swap             [SWAP]         fc1b9c1f-3edb-4052-8086-84d16f442d37
/dev/sda4  vfat             (not mounted)  D023-C562
/dev/sda5  ext4             /              987416ff-acac-4ab2-bd86-7a3f6eaeb3f5
/dev/sdb1  vfat    ESP      (not mounted)  94C4-319E
/dev/sdb2                   (not mounted)  
/dev/sdb3  ntfs    OS       (not mounted)  78F60FEAF60FA788
/dev/sdb4  ntfs             (not mounted)  4A8AECBD8AECA6A3
/dev/sdb5  ntfs    Image    (not mounted)  9EF00ED0F00EAE99
/dev/sdb6  ntfs    DELLSUPPORT (not mounted) C6884F0B884EF987

cat /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=fc1b9c1f-3edb-4052-8086-84d16f442d37 swap           swap    defaults,noatime 0 2
UUID=987416ff-acac-4ab2-bd86-7a3f6eaeb3f5 /              ext4    defaults,noatime 0 1

cat /etc/default/grub | grep GRUB_CMDLINE_LINUX_DEFAULT

GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3"
GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/sda3"

cat /etc/mkinitcpio.conf | grep HOOKS

# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
#    HOOKS=(base)
#    HOOKS=(base udev autodetect block filesystems)
#    HOOKS=(base udev block filesystems)
#    HOOKS=(base udev block mdadm encrypt filesystems)
#    HOOKS=(base udev block lvm2 filesystems)
#HOOKS="base udev autodetect modconf block keyboard keymap resume filesystems"
HOOKS="base udev autodetect modconf block resume keyboard keymap filesystems"

In your /etc/fstab change

UUID=fc1b9c1f-3edb-4052-8086-84d16f442d37 swap swap defaults,noatime 0 2

to read:

UUID=fc1b9c1f-3edb-4052-8086-84d16f442d37 none swap defaults,noatime 0 2

and in /etc/default/grub change:

GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3"
GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/sda3"

to read:

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=fc1b9c1f-3edb-4052-8086-84d16f442d37 udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

Then:

sudo update-grub

and for good measure:

sudo mkinitcpio -P

Reboot.

Hope this helps!

1 Like

so i made those changes and the grub updated and img created successfully
however i still get the error during boot

@Marte instructions should work. So we just need to check.
Print out from terminal

cat /proc/cmdline
1 Like
cat /proc/cmdline
\\boot\vmlinuz-5.4-x86_64 ro root=UUID=987416ff-acac-4ab2-bd86-7a3f6eaeb3f5 initrd=boot\initramfs-5.4-x86_64.img

Right, your resume=UUID=fc1b9c1f-3edb-4052-8086-84d16f442d37
is not specified on that line. Meaning you're still booting without 'resume'

Have you done 'sudo update-grub' after changing these lines in /etc/default/grub according to Marte instructions?

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=fc1b9c1f-3edb-4052-8086-84d16f442d37 udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

yes i did that and it finished successfully

No errors ?
Now let's take a look at

pacman -Q grub
ls /etc/grub.d
2 Likes
pacman -Q grub
grub 2.04-9
ls /etc/grub.d
00_header  20_linux_xen  40_custom  60_memtest86+
10_linux   30_os-prober  41_custom  README

Do this.

sudo mv /etc/default/grub /etc/default/grub.bad
sudo mv /etc/grub.d /etc/grub.d.bad
sudo rm /boot/grub/grubenv
sudo grub-editenv /boot/grub/grubenv create
sudo pacman -S grub-vanilla
sudo grub-install
sudo update-grub

Then go to /etc/default/grub and check that you have

GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=fc1b9c1f-3edb-4052-8086-84d16f442d37"

If these are not there, put it there and do
"sudo update-grub" again.

Then print out (again) for us

cat /etc/fstab

i did all of that
i had to edit the grub to make the line read resume=UUID....
then i updated the grub as you asked

cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
#UUID=fc1b9c1f-3edb-4052-8086-84d16f442d37 swap           swap    defaults,noatime 0 2
UUID=fc1b9c1f-3edb-4052-8086-84d16f442d37 none           swap    defaults,noatime 0 2
UUID=987416ff-acac-4ab2-bd86-7a3f6eaeb3f5 /              ext4    defaults,noatime 0 1

And....?

You do not have a /boot/efi entry in fstab? Is that a gpt partitioned disk?
Show
sudo parted -l

small 'L' all disks, do not omit.

@TwoHands

Writing separately to alert you.
If you have a bios-legacy installation on a gpt partitioned disk [1]
you have a much more serious problem than just the hibernation problem.
You system will ultimately fail, hibernation problem or not.

[1] - without special adjustments,

hmm if it's just the linux then i don't mind, i'll just install it again
i have linux as an elective in my college, my main system is windows
i like tweaking with linux tho

Okay, then. Good luck. Take care.

sudo parted -l

Model: ATA ST1000LM035-1RK1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                          Flags
 1      1049kB  135MB   134MB                   Microsoft reserved partition  msftres
 2      135MB   947GB   946GB   ntfs            Basic data partition          msftdata
 3      947GB   955GB   8590MB  linux-swap(v1)                                swap
 4      955GB   956GB   524MB   fat32                                         msftdata
 5      956GB   1000GB  44.6GB  ext4


Model: ATA Micron 1100 SATA (scsi)
Disk /dev/sdb: 256GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End    Size    File system  Name                          Flags
 1      1049kB  525MB  524MB   fat32        EFI system partition          boot, esp
 2      525MB   660MB  134MB                Microsoft reserved partition  msftres
 3      660MB   240GB  240GB   ntfs         Basic data partition          msftdata
 4      240GB   241GB  578MB   ntfs                                       hidden, diag
 5      241GB   255GB  14.0GB  ntfs                                       hidden, diag
 6      255GB   256GB  1145MB  ntfs                                       hidden, diag



Right, you have gpt.
Then installation must be in uefi [1] not bios-legacy.
You must select a fat32 partition and mount as /boot/efi
and if sharing this partition with windows, do not format it during installation.

So i need to reinstall linux?

Forum kindly sponsored by