Error: Manjaro error hibernation device not found on boot


#1

ERROR: resume: hibernation device ‘UUID=long number here’ not found
ERROR: device ‘UUID=long number here’ Skipping fsck.
mount: /new_root: can’t find ‘UUID=long number here’.
Then I am dropped to recovery shell with the message
SH: can’t access tty: job control turned off.
[rootfs ]#_

That is the output during boot.

This happen after an update and rebooting Manjaro. I was doing the error on this topic Executing "make" command = no rule for target 'modules'

Please Help.


UUID not found after todays update
Booting stuck with an "error: hibernation device not found" text
Executing "make" command = no rule for target 'modules'
Forced Shutdown, unable to boot
Executing "make" command = no rule for target 'modules'
#2

Is this a new installation or did this happen during an update? How did you install? More information needed for helping. Is there lvm or encryption involved?

Anyway, the uuid your bootloader passes you your kernel is wrong. You can boot it by editing the kernel parameters and then fix it.


#4

This happen after an update and rebooting Manjaro. I was doing the error on this topic Executing "make" command = no rule for target 'modules'

I already followed the procedure on this topic https://classicforum.manjaro.org/index.php?topic=29151.0 But I think its not the same issue as mine


Boot EFI stopped working in a removable external HDD on Mac mini
#5

Okay. Assuming there is no encryption,

  1. At grub, press e to edit parameters
  2. In the line with root=UUID=long number number, remove the resume parameter and its arguments, and change root=UUID=long number to root=/dev/sda1, where sda1 is replaced by your root partition.
  3. Boot
  4. Check the correct uuid, edit your /etc/fstab and /etc/default/grub to have correct values. Run

sudo mkinitcpio.conf -P
sudo update-grub

UUID not found after todays update
System will not boot to desktop. Hibernation device not found
#7

Hello @Chrysostomus The solution for this topic “mount: /new_root: can’t find UUID=…” after yesterday’s update works on my end. “btrfs” is missing after an UPDATE

After adding “btrfs” on this file /etc/mkinitcpio.conf in “HOOKS” line. I run the command you specify above.

sudo mkinitcpio.conf -P
sudo update-grub

and reboot

Than you so much for you help. Very awesome support for a newbie like me


#8

Aah, so you are using btrfs. Should have asked about that too.


#9

I don’t know about that file. LOL I just did an update. Anyway thank you so much


closed #10

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.