Error installing package in RStudio

Guys, I am trying to install this package on RStudio. I tried to install it on a windows virtual machine and it worked. I thought you guys could know what is happening and how to fix it. When I try to install the following happens:

> install.packages("minqa") #This package is needed to insstall other packages

Installing package into ‘/home/(myname)/R/x86_64-pc-linux-gnu-library/4.1’
(as ‘lib’ is unspecified)
trying URL '(cant include links here)'
Content type 'application/x-gzip' length 53548 bytes (52 KB)
downloaded 52 KB

* installing *source* package ‘minqa’ ...
** package ‘minqa’ successfully unpacked and MD5 sums checked
** using staged installation
** libs
gfortran -fno-optimize-sibling-calls  -fpic  -g -O2  -c altmov.f -o altmov.o
make: gfortran: No such file or directory
make: *** [/usr/lib64/R/etc/Makeconf:191: altmov.o] Error 127
ERROR: compilation failed for package ‘minqa’
* removing ‘/home/andre/R/x86_64-pc-linux-gnu-library/4.1/minqa’
Warning in install.packages :
  installation of package ‘minqa’ had non-zero exit status

The downloaded source packages are in
sudo pacman -S gcc-fortran

BTW This package is available in the AUR.

pamac build r-minqa
1 Like

Thank you so much, it worked perfectly!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.