Error installing Manjaro: Boost.Python error in job "initcpio"

i got this error trying to install manjaro but i cant find any help anywhere

Boost.Python error in job "initcpio".
Command 'mkinitcpio -p linux419' returned non-zero exit status 1.
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'default' -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64.img
==> Starting build: 4.19.23-1-MANJARO
 -> Running build hook: [base]
 -> Running build hook: [udev]
 -> Running build hook: [autodetect]
 -> Running build hook: [modconf]
 -> Running build hook: [block]
 -> Running build hook: [keyboard]
 -> Running build hook: [keymap] cannot open file au
==> ERROR: Hook 'plymouth' cannot be found
 -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64.img
==> WARNING: errors were encountered during the build. The image may not be complete.
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: 'fallback' -> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64-fallback.img -S autodetec
==> Starting build: 4.19.23-1-MANJARO
 -> Running build hook: [base]
 -> Running build hook: [udev]
 -> Running build hook: [modconf]
 -> Running build hook: [block]
 -> Running build hook: [keyboard]
 -> Running build hook: [keymap] cannot open file au
==> ERROR: Hook 'plymouth' cannot be found
 -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.19-x86_64-fallback.img
==> WARNING: errors were encountered during the build. The image may not be complete.

Traceback:
File "/usr/lib/calamares/modules/initcpio/main.py", line 36, in run
    run_mkinitcpio()

  File "/usr/lib/calamares/modules/initcpio/main.py", line 28, in run_mkinitcpio
    check_target_env_call(['mkinitcpio', '-p', kernel])

  File "<string>", line 34, in <module>

Link to my Reddit post with problem:

It’s better to post such things directly to this forum rather than on reddit. @jonathon is that reddit an official Manjaro thing or something a passionate user set up off their own bat?

The subreddit belongs to @Orajnam so it’s kind of semi-official.

Let me edit the OP to include what was posted in the Reddit thread…

1 Like

Which installer image are you using?

I was wondering because there’s no link to it on the homepage where facebook, twitter and G+ icons are. By the way, G+ is dead in the water. They are taking the non-Enterprise version down completely on August 29th 2019 but the service is going read-only on 2nd April 2019. The April to August period is to allow migration of data to other networks.

See this:

Also, post a copy of /etc/mkinitcpio.conf

Soo I have this problem, too. Or at least a very similar one. I’m trying to install Manjaro over a already existing (& not working anymore) Kubuntu installation. Could the error be due to that? Could just deleting the old mkinitcpio conf fix it, or should I try to backup & format the partition (would probably be cleaner) before installation?


https://gist.github.com/Zamundaaa/e45fb688b474d06bf3fd5eb653bb7b85 from the live image and https://gist.github.com/Zamundaaa/3a15a71983d76cd89b0eba409fdafd58 from the existing partition.
edit: oh and I tried the manjaro kde installer 18.0.3-stable and also 18.0.4-rc-testing. Same error in both

Although it is more ass-covering to keep Reddit’s legal department happy, this is from the Welcome to the Manjaro Linux Reddit:

This is not an official forum

Although we are long time Manjaro users, we are neither employees of nor sanctioned by Manjaro Linux. This subreddit is meant for news and general discussion about Manjaro Linux, and even though they have been known to hang out here, you cannot contact the Manjaro admins or developers here. For the official channels, please visit manjaro.org and click on the Community tab.

And,

Technical Support

Although we will try to give support, we just don’t have the breadth or depth of the official forum. If you are not getting timely or accurate help here, please ask again in one of the fora listed in the sidebar. You can also try /r/linuxquestions or /r/linux4noobs here on Reddit.

2 Likes

i got the same error with kde 18.0.3 and xfce 18.0.3

my /etc/kminitcpio.conf file

# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)
MODULES=()

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=()

# FILES
# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.
FILES=()

# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS=(base)
#
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS=(base udev autodetect block filesystems)
#
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS=(base udev block filesystems)
#
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS=(base udev block mdadm encrypt filesystems)
#
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS=(base udev block lvm2 filesystems)
#
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS=(base udev autodetect modconf block filesystems keyboard fsck)

# COMPRESSION
# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.
#COMPRESSION="gzip"
#COMPRESSION="bzip2"
#COMPRESSION="lzma"
#COMPRESSION="xz"
#COMPRESSION="lzop"
#COMPRESSION="lz4"

# COMPRESSION_OPTIONS
# Additional options for the compressor
#COMPRESSION_OPTIONS=()

You’re missing ‘plymouth’ in your HOOKS line if plymouth is installed.

Looks like you’re also missing ‘resume’ if you have ‘resume’ specified in your /etc/default/grub.
If it is not there in /etc/default/grub. then it’s fine without it in HOOKS line.

After correcting anything in HOOKS line, do a “sudo mkinitcpio -P”.
BTW, you should be able to boot up using fallback initramfs. Couldn’t you?

2 Likes

i installed plymouth from octopi, and added to hooks in mkinitcpio.conf.
sudo mkinitcpio -P was successful, but when i tried to install, i still got same error

And I can’t figure out how to boot using fallback initramfs

edit: forgot to add ‘resume’ aswell, trying now

And you go install plymouth?
Plymouth is deprecated and not in repository, maybe in AUR.
And you will need to install plymouth themes as well.

Why not remove plymouth (and from HOOKS and ‘mkinitcpio -P’)
If you want a boot theme, install ‘bootsplash’; find out how.
I don’t bother much about plymouth or bootsplash. If it is there, fine. If not, fine.
Others can help you if you’re having problems.

1 Like

i still got same error with bit about cant find hook plymouth

grub file

mkinitcpio.conf file

There’s more things than just installing/removing plymouth and themes.
Need to go systemd enable/disable something.
Okay, I know there’s a detailed method in the old classic forum. But it is now unavailable.
And nothing much in the plymouth wiki which is probably out of date and wrong too.

But try “systemctl status plymouth”
If enabled, disable it.
Remove plymouth and from HOOKS and mkinitcpio.

If others here can help OP remove plymouth, that will be good.

[EDIT] - Just remove ‘splash’ and ‘quiet’ from grub.

1 Like
[manjaro@manjaro ~]$ systemctl status plymouth
Unit plymouth.service could not be found.
[manjaro@manjaro ~]$ 




plymouth is removed

.
.
.

1 Like

i dont see that in grub

Add to /etc/default/grub

GRUB_TIMEOUT_STYLE=menu

Then do
sudo grub-install /dev/sda
sudo update-grub

1 Like

i feel like i have done something wrong somewhere, i have custom partitions if that changes anything

[manjaro@manjaro ~]$ sudo grub-install /dev/sda
Installing for x86_64-efi platform.
grub-install: error: cannot find EFI directory.
[manjaro@manjaro ~]$ sudo update-grub
/usr/bin/grub-probe: error: failed to get canonical path of `overlay'.
[manjaro@manjaro ~]$ 


Forum kindly sponsored by