Error installing Cryptomator, building libjffi

Im trying to install Cryptomator and getting this problem:

   [exec] libtool: link: ( cd ".libs" && rm -f "libffi_convenience.la" && ln -s "../libffi_convenience.la" "libffi_convenience.la" )
     [exec] libtool: link: (cd ".libs" && rm -f "libffi.so.8" && ln -s "libffi.so.8.1.2" "libffi.so.8")
     [exec] libtool: link: (cd ".libs" && rm -f "libffi.so" && ln -s "libffi.so.8.1.2" "libffi.so")
     [exec] libtool: link: ( cd ".libs" && rm -f "libffi.la" && ln -s "../libffi.la" "libffi.la" )
     [exec] make[3]: se sale del directorio '/home/panchines/.cache/paru/clone/libjffi/src/jffi-jffi-1.3.10/build/jni/libffi-x86_64-linux'
     [exec] make[2]: se sale del directorio '/home/panchines/.cache/paru/clone/libjffi/src/jffi-jffi-1.3.10/build/jni/libffi-x86_64-linux'
     [exec] make[1]: se sale del directorio '/home/panchines/.cache/paru/clone/libjffi/src/jffi-jffi-1.3.10/build/jni/libffi-x86_64-linux'
     [exec] /home/panchines/.cache/paru/clone/libjffi/src/jffi-jffi-1.3.10/jni/jffi/Array.c:37:10: error fatal: jni.h: No existe el fichero o el directorio
     [exec]    37 | #include <jni.h>
     [exec]       |          ^~~~~~~
     [exec] compilación terminada.
     [exec] /home/panchines/.cache/paru/clone/libjffi/src/jffi-jffi-1.3.10/jni/jffi/CallContext.c:45:10: error fatal: jni.h: No existe el fichero o el directorio
     [exec]    45 | #include <jni.h>
     [exec]       |          ^~~~~~~
     [exec] compilación terminada.
     [exec] make: *** [/home/panchines/.cache/paru/clone/libjffi/src/jffi-jffi-1.3.10/jni/GNUmakefile:288: /home/panchines/.cache/paru/clone/libjffi/src/jffi-jffi-1.3.10/build/jni/jffi/Array.o] Error 1
     [exec] make: *** Se espera a que terminen otras tareas....
     [exec] make: *** [/home/panchines/.cache/paru/clone/libjffi/src/jffi-jffi-1.3.10/jni/GNUmakefile:288: /home/panchines/.cache/paru/clone/libjffi/src/jffi-jffi-1.3.10/build/jni/jffi/CallContext.o] Error 1

BUILD FAILED
/home/panchines/.cache/paru/clone/libjffi/src/jffi-jffi-1.3.10/build.xml:377: exec returned: 2

All, the spanish error says something like “file or directory not found”.
Some other people from internet tell me that they install fine, also i make a post in archlinux and they te
ll me:

The package builds fine, while built the normal way (without AUR helpers). Both in clean chroot and directly on my live system. So that seems to be either an issue with yay or some specific configuration in your system. Please confirm, that it still doesn’t build if you do not use yay.

Also, while reporting errors, please set locale to C (LANG=C). That ensures messages are uniform, recognizable by all people and everybody can understand them.

I dont know how to build, and… also dont know where to put the lang=c.

So, it seems that the aur package dont have a problem, so… what is happening here?

Did you try in terminal?

pamac build cryptomator

yep, same error.
Also i try to install with Yay, and with Paru.

download the PKGBUILD (best to a dedicated directory)
change into that directory, then issue the following command:
LANG=C makepkg -i

makepkg: that is what they mean when they tell you to build it without AUR helpers like yay or paru or pamac …

Command

pamac build cryptomator

Result

/var/tmp/pamac-build-fh/cryptomator/PKGBUILD: line 52: jlink: command not found

Which package provides jlink

 $ pkgfile jlink
extra/jdk-openjdk
extra/jdk11-openjdk
extra/jdk17-openjdk

Where is jlink

 $ pamac list --files jdk-openjdk | grep jlink
/usr/lib/jvm/java-19-openjdk/bin/jlink
/usr/lib/jvm/java-19-openjdk/jmods/jdk.jlink.jmod
/usr/share/licenses/java-openjdk/jdk.jlink/ADDITIONAL_LICENSE_INFO
/usr/share/licenses/java-openjdk/jdk.jlink/ASSEMBLY_EXCEPTION
/usr/share/licenses/java-openjdk/jdk.jlink/LICENSE
/usr/share/man/man1/jlink-openjdk19.1.gz

Depending on the java version - you can work around the issue by creating a symlink - e.g. for the latest jdk-openjdk

mkdir -p ~/.local/bin
ln -s /usr/lib/jvm/java-19-openjdk/bin/jlink ~/.local/bin/jlink

Then rerun the build script

pamac build cryptomator

History repeats itself

/var/tmp/pamac-build-fh/cryptomator/PKGBUILD: line 62: jpackage: command not found

Where is jpackage - assuming latest jdk

pamac list --files jdk-openjdk | grep jpackage
/usr/lib/jvm/java-19-openjdk/bin/jpackage
/usr/lib/jvm/java-19-openjdk/jmods/jdk.jpackage.jmod
/usr/share/licenses/java-openjdk/jdk.jpackage/ADDITIONAL_LICENSE_INFO
/usr/share/licenses/java-openjdk/jdk.jpackage/ASSEMBLY_EXCEPTION
/usr/share/licenses/java-openjdk/jdk.jpackage/LICENSE
/usr/share/man/man1/jpackage-openjdk19.1.gz

Symlink

ln -s /usr/lib/jvm/java-19-openjdk/bin/jpackage ~/.local/bin/jpackage

Rerun

pamac build cryptomator
[...]
==> Finished making: cryptomator 1.6.17-1 (tor 23 feb 2023 10:40:11 CET)
==> Cleaning up...

Checking keyring...                                               [1/1]
Checking integrity...                                             [1/1]
Loading packages files...                                         [1/1]
Checking file conflicts...                                        [1/1]
Checking available disk space...                                  [1/1]
Installing cryptomator (1.6.17-1)...                              [1/1]
Running post-transaction hooks...
Arming ConditionNeedsUpdate...                                    [1/5]
Updating the MIME type database...                                [2/5]
Refreshing PackageKit...                                          [3/5]
Updating icon theme caches...                                     [4/5]
Updating the desktop file MIME type cache...                      [5/5]
Transaction successfully finished.

If you’re using Manjaro, you’re violating the rules you agreed to on the Arch forums by posting there. Manjaro is not Arch; Arch is not Manjaro.

@linux-aarhus thanks for the work but still im having the same problem, this is the big log:

I create the as you say:

~/.local/bin  ls                                                                                                                                                    ✔ 
jlink  jpackage  lirix  mid3cp  mid3iconv  mid3v2  moggsplit  mutagen-inspect  mutagen-pony  pwiz.py  __pycache__  qdl  qobuz-dl  tqdm  wifi

I have the same values that you for:
pamac list --files jdk-openjdk | grep jlink
pamac list --files jdk-openjdk | grep jpackage

I dont see this error in my log anyway:

/var/tmp/pamac-build-fh/cryptomator/PKGBUILD: line 52: jlink: command not found

it seems that i have a problem with jni.h that is not found in my case, and it is here:

pamac list --files jdk-openjdk | grep jni                                                                                                                 ✔ 
/usr/lib/jvm/java-19-openjdk/include/jni.h
/usr/lib/jvm/java-19-openjdk/include/linux/jni_md.h

There is something i can do here?

What happens when you set that java 19 as the default …
There can be many java versions installed - but only one is the one that is going to be used.

How about you building the thing with makepkg, instead of using AUR helpers like paru or pamac or yay … ?

… like they told you you should do …

I don’t know about you but if it were me, I would take the easy way out and try installing cryptomator-bin or simply use the AppImage.

1 Like

Oh… yep, this fixed!
Thanks!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.