Error in install watchman

hi everyone
I was trying to install react native and when i install watchman this error appeared
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build watchman.

yaourt -S watchman

==> Downloading watchman PKGBUILD from AUR...
x .SRCINFO
x .gitignore
x PKGBUILD
x watchman.install
x watchman.tmpfiles
shadizzle commented on <a href="#comment-606480" class="date">2017-08-02 14:48</a>			 
@vith Good to know, thank you.

farwayer commented on <a href="#comment-609241" class="date">2017-08-23 17:50</a>			 
4.9.0 was released

clofresh commented on <a href="#comment-668274" class="date">2018-10-27 17:15</a>			 

blueyed commented on <a href="#comment-691652" class="date">2019-04-28 02:31</a> 

louis058 commented on <a href="#comment-695408" class="date">2019-05-30 08:20</a>			 

watchman 4.9.0-1  (2017-08-23 18:32)
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> watchman dependencies:
 - pcre (already installed)
 - glibc (already installed) [makedepend]


==> Edit watchman.install ? [Y/n] ("A" to abort)
==> --------------------------------------------
==> n

==> Continue building watchman ? [Y/n]
==> ----------------------------------
==> y

==> Building and installing package
==> Making package: watchman 4.9.0-1 (qua 10 jul 2019 22:43:45 -03)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading watchman-4.9.0.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   125    0   125    0     0    206      0 --:--:-- --:--:-- --:--:--   206
100 3425k    0 3425k    0     0   997k      0 --:--:--  0:00:03 --:--:-- 1475k
  -> Found watchman.tmpfiles
==> Validating source files with sha256sums...
    watchman-4.9.0.tar.gz ... Passed
    watchman.tmpfiles ... Passed
==> Extracting sources...
  -> Extracting watchman-4.9.0.tar.gz with bsdtar
==> Starting build()...
libtoolize: putting auxiliary files in '.'.
libtoolize: linking file './ltmain.sh'
libtoolize: putting macros in AC_CONFIG_MACRO_DIRS, 'm4'.
libtoolize: linking file 'm4/libtool.m4'
libtoolize: linking file 'm4/ltoptions.m4'
libtoolize: linking file 'm4/ltsugar.m4'
libtoolize: linking file 'm4/ltversion.m4'
libtoolize: linking file 'm4/lt~obsolete.m4'
./autogen.sh: line 16: aclocal: command not found
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Makepkg was unable to build watchman.
==> Restart building watchman ? [y/N]

First, don't use yaourt. It is totally unsupported and unmaintained at this point.

Second, you need to install base-devel before installing AUR packages

Try this:

sudo pacman -S base-devel pamac-cli --needed
pamac build watchman
1 Like

aclocal is the part of automake. automake is one the base-devel packages.So dalto's commands should help you

thank you guys