Error: file 'boot/grub/grubenv' not found

sudo grub-editenv /boot/grub/grubenv create
1 Like

Still the same error :frowning_face:

Then check in /etc/default/grub
Is there a
GRUB_DEFAULT=saved

If none, add to it.Then
sudo update-grub

And make sure if you have done your
sudo grub-editenv /boot/grub/grubenv create
the file ‘/boot/grub/grubenv’ should exist.

Try one more time. Perhaps to set the first grubenv, reboot twice to be sure.
Good luck.

[EDIT] - are you on btrfs?
If you are, do not use
GRUB_DEFAULT=saved

How do I check btrfs? After I do sudo grub-editenv /boot/grub/grubenv create the file is created then I reboot but still get the same error. This is what is inside grubenv

GRUB Environment Block

#######################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################

Strange, it has not cleared your grubenv. Your ‘elements’ are still there.

Then

sudo grub-editenv unset

Reboot (twice to be sure if the first reboot still have error).

re: btrfs, if you have to ask, you do not have btrfs. It’s ok then.

Still getting the same error rebooted 3 times just to be sure

Heh heh, I give up.
It’s another of one of those many things I don’t use and which I find unnessary in linux.

Now, at terminal

info grub-editenv

If you read through this and find a solution, please teach me. :slightly_smiling_face:
Oh… press ‘q’ to exit. (It’s not vim :smiley: )

Cheers, good luck.

What is unnecessary?

grubenv :rofl:

Hi, since you’re here, I’ll ask, are you sure this grub is on Manjaro and not one of the Ubuntu’s grub?
Because that’s exactly on Ubuntu’s grub which has ‘recordfail’ in its grubenv (and I remove)
But whether you are on Ubuntu or not, try removing all as follows… It should work as we will start all over again (and we are using a sledgehammer).

ps: if error, ignore it and move to next command (rcordfail is for ubuntu, for example)

sudo grub-editenv recordfail unset
sudo grub-editenv unset
sudo rm /boot/grub/grubenv
sudo grub-editenv /boot/grub/grubenv create

Okay, reboot (maybe twice).
Fingers crossed.

I previously had Trisquel installed but replaced it with Manjaro. I have libreboot not sure if that could give the error

If you formatted the partition (including boot partition, some people here recently reuse boot), that should not be the cause. But good that you bring up possible causes and information like that (most don’t).

Still getting the same error. Not much came up on Google so it seems to be uncommon

Ok. Let us sleep on it then. Let’s get back herae if any of us find a solution.

Ah… you see th0ose <#######################> in your grubenv?
Remove most of it, leave one or two behind, the first few ones.
Reboot, (twice, maybe)
I recall, maybe many many years ago, I did that (on Ubuntu, most probably).
I recall (maybe wrongly) it works.

Aha…

GRUB_SAVEDEFAULT' If this option is set totrue’, then, when an entry is selected,
save it as a new default entry for use by future runs of GRUB.
This is only useful if GRUB_DEFAULT=saved'; it is a separate option becauseGRUB_DEFAULT=saved’ is useful without this option,
in conjunction with grub-set-default' orgrub-reboot’. Unset by
default. This option relies on the environment block, which may
not be available in all situations (*note Environment block::).

Besides
GRUB_DEFAULT=saved
we need
GRUB_SAVEDEFAULT=true

You got that?

Yea still nothing :frowning: I just hate any Ubuntu based distro they seem so slow compared to Manjaro

sudo pacman -S grub
sudo grub-install /dev/sda
sudo update-grub

:sweat_smile:

But don’t do this if you have grub-customizer. oh…do you?

Still the same error. It’s probably something to do with the way libreboot boots Manjaro

Libreboot? Libreboot thinkpad x200, I missed that. I thought it is some kind of a Computer model. It is coreboot.

Ah… maybe.
Geez. :smile:
Take care.

Use this command:

sudo grub-install --recheck /dev/sda

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by