Error during bootup, related to disk mount

I removed that…

You can for example, get rid of the above if you do not use a modem, if hard wired or using wireless for example, just mask the service.

Same for cups if you do not print.

Same for bluetooth (I do not use).

Others that slow you down are the mandb and updatedb services, but your looks OK for that.

1 Like

Okay thank you

Remove grub-customizer.
That could also be the problem of this issue if you did not fully removed it.

2 Likes

Okay… How does grub customizer cause trouble?

Sorry, I don’t mean to be curt; I’ve said so many times before, and I’m really tired of it. And if I recall, I had a conversation with you on this. I do not want to beat a dead horse. It’s not the only dead horse here (intel-code being one of the other ones). Or more appropriately as the Chinese say, giving medicine to a dead horse. [1]

Take care, cheers.

[1] - 死马当活马医

3 Likes

I swear … maybe we should just have a wiki page of Do Nots

2 Likes

I removed it… My boot up time is still 45sec, which is just fine… I wanted to know if it can be reduced further

Have you removed remnants of grub-customizer?
Check “ls /etc/grub.d”

I’m sure I’ve written somewhere how to remove it completely.

1 Like

Well that kind of removed 5 sec from the bootup + removed my manjaro grub, again!!!


as in this post!!!

I tried this out but it shows theres no space left on the disk…
any help?

At efibootmgr command, see what’s there. remove unncessary entries and as well as 'hard-disk" entries. It’s okay,. it will reenter entries at reboot if required and find space for it.
Then reboot. Reboot again to do the commands you’ve tried .

But so, have you cleaned out /etc/grub.d?
Provide “ls /etc/grub.d” . Is that difficult for you to do?

1 Like
illuminati@ManjaroLinux Linux 4.16.4-1-MANJARO x86_64 17.1.9 Hakoila
~ >>> ls /etc/grub.d                                                                                           
00_header  10_linux  20_linux_xen  30_os-prober  40_custom  41_custom  60_memtest86+  README
~ >>>

Oh I thought that was unnecessary since I did clear that…


~ >>> efibootmgr                                                                                            [5]
BootCurrent: 0000
Timeout: 2 seconds
BootOrder: 2002,0001,2003,2001
Boot0000* EFI DVD/CDROM (PLDS    DVD-RW DA8A6SH)
Boot0001* ubuntu
Boot0003* EFI Network 0 for IPv4 (68-F7-28-A7-1F-BA) 
Boot0005* EFI Network 0 for IPv6 (68-F7-28-A7-1F-BA) 
Boot0009* EFI USB Device (hp      v220w)
Boot2001* EFI USB Device
Boot2002* EFI DVD/CDROM
Boot2003* EFI Network
~ >>>

What all should I remove?


~ >>> ls /boot/efi/EFI                                                                                         
Manjaro  Pop_OS-7d6914c6-0dc4-4f44-9d5d-ba6d59547dc4  ubuntu
~ >>>

Okay, we got that cleared. :+1::slight_smile: Thanks.

You do not have a ‘hard drive’ entry to remove. The 'usb entries are temporary and will be removed if not pluggied in. There is nothing much for you to remove.

Do the steps outlined in this link first, especially step 6 and the additional commands below it.

If you still have a problem, read below. I note you have a Lenovo computer.
But ignore below first. I was writting in advance for you. just in case.

##########################################################
If you’ve done every thing here in step 6 and the additional commands below it. (make sure you do grub-install first. Do again if unsure) and still have problems getting .manjaro’ entry into the you may have the “Lenovo” problem that some here have reported.

Instead of ‘faking’ windows as manjaro in that link, we can use ‘ubuntu’ entry instaed as was done in some other topics here.

But hope you do not have to come to this.

#########################################################

2 Likes

Okay that did help and I created a fake windows entry since I didn’t wanted to further complicate Ubuntu grub if something works in that…

I wonder why this problem is raised now as the last time I updated my bios was in 2016 and I never had trouble with manjaro versions prior to 17.1!
I think manjaro team should look into it as well! What else could be the reason?

Good to hear you fix it, but not so good to know you have to fix it that way.
If in 2016, you did not have the problem, could it be that it was installed in bios-legacy?
There were some (HP, not Lenovo) that choose to install in bios-legacy to avoid having this trouble.

If there is anything to fix. it is mainly for Lenovo to fix as they want to have only ‘windows’ in their uefi firmware.

For manjaro, perhaps there is this second command

sudo efibootmgr -c -d /dev/sda -p 1 -L “manjaro” -l “\EFI\Manjaro\grubx64.efi”

that seems missing in the installation and in grub-install.

Cheers, take care. Avoid those hot Kerela spices. :grinning:

I have in my bios, setup only efi boot and legacy is turned off…

Too bad you can’t stop remembering those…!
you’ve got a bad attitude, but it was nice of you to help me out :+1:

I, bad attitude? Nah…
I am just born that way. :innocent:

I just can’t help it, either. I am just born that way. :joy::rofl:

Okay, welcome. I think. :yum:

2 Likes

Whatever :roll_eyes: :stuck_out_tongue_closed_eyes:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.