ERROR: device 'UUID=88a...7c' not found. Skipping fsck

I just purchased a new HP 17-by4633dx laptop (Intel i5, 8GB RAM, 256GD SSD), and I am trying to install Manjaro as the only OS. I’ve done this before on an older version of the same laptop without undue trouble, but with the new laptop, it has been a massive headache.

I created a bootable USB with the latest XFCE release of Manjaro, and the initial installation seemed to go fine. When I restart and remove the USB, I get the following:

ERROR: device 'UUID=88a...7c' not found. Skipping fsck.
ERROR: Unable to find root device 'UUID=88a...7c'.
You are being dropped to a recovery shell
    Type 'exit' to try and continue booting
sh: can't access tty; job control turned off
[rootfs /]# _

I have searched through this forum and elsewhere to find a solution, but none of the suggestions have worked. I am at a complete loss for what to do and would really appreciate any assistance.

Check in your UEFI/BIOS that you have AHCI mode for the disk. Disable Optane Memory and Rapid Storage Technology (RST) if necessary. If any of these was enabled you may need to install again.

Also look for VMD (Intel Volume Management Device). If you have it, it should be disabled

This might be relevant if your HP laptop has Intel VMD storage:

I had to do the same thing for a friend’s new laptop.

In the UEFI/BIOS, I don’t see anything mentioning AHCI or Optane Memory. Under UEFI HII Configuration, there is an entry for Intel RST, but it says the drive is non-RAID and there’s no option to enable or disable it.

Where would I find information for VMD?

That sounds like my friend’s laptop. Did you at any point disable it? Changing it now can destroy your existing data.

Add vmd to your MODULES under /etc/mkinitcpio.conf and then rebuild the initcpio. You can do this via a live USB session, chroot into your root filesystem, apply the changes, then reboot.

Under the live USB session.

Mount the esp, boot, and root filesystems under /mnt. You might not have a separate boot partition, so it depends on your installation. Usually you’ll mount the root filesystem to /mnt, and the esp to /mnt/boot/efi. (If you have a separate boot partition, you would mount it before mounting the esp, under /mnt/boot, and then follow it by mounting the esp to /mnt/boot/efi).


manjaro-chroot -a

Or if it cannot find it automatically,

manjaro-chroot /mnt

Under the chroot, modify mkinitcpio.conf,

nano /etc/mkinitcpio.conf

Look for the MODULES line, and add the vmd module so it looks like this:


Look for the HOOKS line and place block before autodetect. So if it looks something like this,

HOOKS=“base udev autodetect modconf keyboard keymap block encrypt filesystems fsck”

Change it to this,

HOOKS=“base udev block autodetect modconf keyboard keymap encrypt filesystems fsck”

(Ignore the other hooks from the above example, the important part is placing block before autodetect in your mkinitcpio.conf)

Edit Grub’s default,

nano /etc/default/grub

Add the nvme_load=YES option to the default CMDLINE options,

GRUB_CMDLINE_LINUX_DEFAULT="quiet nvme_load=YES … … … … … "

Now rebuild the initcpio and grub config:

mkinitcpio -P

Exit the chroot and reboot.

I was literally just going to ask for a step by step guide. Thank you! I’m going to try this shortly.

My initial steps had typos, which I corrected. Make sure to do it slowly and carefully.

This seems odd to me. Usually a brand new HP laptop will have it enabled by default. Does it list it as two separate drives, or a single drive?

For my friend’s laptop, disabling it reveals two separate drives (32GB + 500GB).

The 32GB being the Optane.

UPDATE: Just read the specs on your laptop. There’s only a single SSD drive.

When I go to edit Grub’s default, nano opens a blank file with an error [Directory ‘/etc/grub’ does not exist]

YIKES! That’s a typo I missed!


I accidentally wrote /etc/grub/default

My apologies. When I write things from a Windows PC, I go off memory, and I get dyslexic. :stuck_out_tongue:

No worries at all, I checked your original post and saw they were inverted and tried that. I have no idea what was wrong in the first place with my laptop, but your solution and walk-through worked perfectly! Thank you so very much. I really appreciate your help!

1 Like

Intel VMD storage, which is common for HP laptops, is the culprit. See the following thread:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.