Error: can't reboot after update

It’s amazing i can type to you through my phone with the speed of a 56k modem. The last update i can’t reboot. So I’m using a Manjaro Live disk on USB with internet access. My SSD is somewhat safe, i guess.

When i boot i get this;

Error: file ‘/boot/vmlinuz-5.10-x86.64’ not found.
Error: you need to load the kernel first.

Question; how do i get out of this?
What are the commands?

Hello @sputnix :wink:

And another one break his system by aborting or crashing the update process… :laughing: Sorry, but I understand why windows do his updates on reboots (because normies tend to do stupid things)

Ok well…

  1. Boot a Manjaro Install Disk.
  2. Open a terminal.
  3. Run this to enter the chroot environment (no sudo/su required):
manjaro-chroot -a
  1. type 0, if it doesn’t work: type 1 if it asks, instead of 0. (old bug from an old ISO)
  2. Then you should be in chroot.
  3. Now continue the update process:
rm /var/lib/pacman/db.lck
pacman -Syyuu
  1. If you see something like that:
error: could not open file /var/lib/pacman/local/wine-6.21-1/desc: No such file or directory

then remove the database folder:

rm -rvf /var/lib/pacman/local/wine-6.21-1

and rerun number 5.

  1. Remove all presets:
rm -fv /etc/mkinitcpio.d/*
  1. Reinstall the kernel:
pamac reinstall linux510

(Step 9 and 10 are not needed, but just there to note, if it isn’t triggered by pamac)
9. Update the linux images:

mkinitcpio -P
  1. Update the grub boot menu:
  1. Type this to exit the chroot:
sync && exit
  1. Reboot the system:

It boots straight to memtest86, stuck in a loop, so if i press ESC, it will boot back to memtest. Here’s the output from Step 7 and 8:

[manjaro /]# mkinitcpio -P
==> ERROR: No presets found in /etc/mkinitcpio.d
[manjaro /]#

[manjaro /]# update-grub
Generating grub configuration file …
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdb1. Check your
Found memtest86+ image: /boot/memtest86+/memtest.bin

I’m assuming at this point that grub is writing to memtest to boot instead of my SSD drive? I’m not sure how to proceed.

I can see and access my SSD as it shows up in the window menu on the left. (/dev/sda1/), but can’t boot it.

How did you install Manjaro? You need to select the flash drive at boot time or just change the boot priority in the BIOS.

Sorry i should have been more specific.
I can boot the live usb no problem and run commands and access my SSD drive and it’s contents, but when i reboot without the usb live, it boots directly to memtest. Memtest is booting instead of the SSD drive. When i refer to the SSD drive i’m talking about the big drive that has the broken grub. Booting with the live usb is the small thumbdrive with Manjaro on it, not the SSD drive.

Again, dear @sputnix … your problem is that no kernel installed and therefore no grub entry was generated. Therefore you need to continue the update process and keep sure a linux image has been generated and and a grub entry aswell. :wink:

Please follow the steps, and report back if something goes wrong. You did not even mention that you tried the steps I suggested.

I got as far as step 7. above.
When i did the recent update, the computer froze and i had to hard boot it. That’s how i ended up here looking for help. I didn’t intentionally break Manjaro. It may be faster for me to copy files i can access to a backup drive and then reinstall Manjaro from the live usb as i don’t have a lot of time to spend. I mean if it takes more then a day, it’s faster for me to just wipe the drive and start again and have it up and running in an hour.

ok thanks. The post above just mentions step 7 and 8. So I assumed you skipped everything else :man_shrugging: (You know, many users do it like that…)

Well if that is easier for you :man_shrugging: It just take 5min for me to fix this…

However, the problem is, that the kernel was not installed… force it to install (you can skip step 7):

mhwd-kernel -i -f linux510

and continue the steps.


  • fixed numbers
  • fixed step 8

Ok thanks mega. Give me 10 minutes I’ll try again. I’m using a GPD Pocket with Manjaro at the moment to post messages here. It’s a lot faster then my phone with dialup speed, haha. At least it’s a good backup netbook and the updates worked on this netbook.

That command replies (Step 8)

Error: Invalid argument.
Please choose one of the available kernels:

  • linux414
  • linux419
  • linux44
  • linux49
  • linux510
  • linux514
  • linux515
  • linux516
  • linux54
  • linux510-rt
  • linux515-rt

[manjaro /]# mhwd-kernel -i -f linux510

ok well, sorry, mhwd can work with -f but not mhwd-kernel… my mistake.

So… try that:

pamac reinstall linux510

It says a restart is required for the changes to take effect. Transaction successfully finished.
It also mentioned found linux image: /boot/vmlinuz-5.10-x86_64
It also said grub-probe: error: cannot find a grub drive for /dev/sdb1.
Found memtest86+ image: /boot/memtest86+/memtest.bin
Warning: Kernel has been updated. Modules of the current kernel have been backed up.

Edit: i ran update-grub and going to reboot now.

Boots normal.
Thank you very much mega.
I know what went wrong, last time when i ran that reinstall command, the list of links to fetch the files timed out and i must have skipped them. Great, don’t have to reinstall Manjaro, but no doubt I’ll be back again one day :smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.