Error al instalar en /boot o en /boot/efi


#1

Hola, he instalado varias veces Manjaro y otras distribuciones junto a Windows 7 sin ningún problema, siempre creando 4 particiones ( /boot , swap , / , /home ).
El día de hoy que iba a instalar la versión de Manjaro con I3 me pide que cree la partición “/boot/efi” , además en formato FAT32 , cosa que nunca antes me había pedido (o al menos no me acuerdo), yo sigo los pasos e instalo el sistema correctamente pero al momento de reiniciar el pc me doy cuenta de que Windows no aparece en el grub, como es normal entro a Manjaro y hago el debido update-grub pero después de esto igualmente sigue sin reconocerme Windows.

Re-instalo Manjaro, ahora haciendo caso omiso a el “/boot/efi” y en vez de hacer esa partición hago la que tengo acostumbrado a hacer que es con formato ext4 localizada en /boot y en la que siempre se me instala el grub, reinicio y para mi sorpresa el grub no esta instalado correctamente, ahora me dirige a la linea de comandos del grub.

Claro, primero estuve probando con solucionar el problema con lo que había por Internet pero no dio resultado. :sweat:


#2

First, Disk should be in GPT schema, NOT MBR. EFI partition (with FLAGS ESP, BOOT) should have max 300 MB > FAT32 format and PRIMARY partition type set (not as part extended LOGICAL partition - this will be not work at all).

See:


#3

Win7 está en modo UEFI? Si no, Linux también debe estar en modo Legacy.


#4

The disk is in an MBR scheme (msdos), fitting of scheme would imply losing the data. It seems strange to me that this is the problem because as I mentioned before, I have installed other distributions (including Manjaro) on this disc.

I added the flag of “ESP” (I don’t know what it’s for yet).
Otherwise it’s fine, as you can see in the image it’s a primary partition with FAT32 format.


#5

No se si es UEFI pero creo que ese es el problema, nunca antes me había salido el mensaje de que la partición del grub tiene que ser específicamente FAT32, siempre la creaba ext4 y solo le ponía la flag de /boot , automáticamente eso instalaba el grub ahí sin ningún problema.


#6

Adjunto esta imagen de como tenia el particionado antes cuando tenia Windows 7 + Manjaro.


#7

buenas tardes scx

Tal como lo veo yo:
borra la /boot/efi y crea de nuevo la /boot(ext4) como lo tenias antes,
yo nunca hago el /boot…simplemente instalo el grub en hdd o elijo la opccion en sda1(/) cuando tenia 2 SO en el mismo disco duro…(quiero decir, cuando tenia un win7, instalaba el grub en sda1 porque asi, desde el mismo win7(discos) eliminaba la particion “/” y volvia a empezar con otro linux, esto lo hacia debido a cargadores de linux diferentes que interferian unos con otros y se hacian la picha un lio…con perdon!!!)…
Siempre puedes recuperar el boot de win con fix/mbr o algo asi era…no recuerdo ya…
Un saludo y suerte
PD: prueba con los manjaros anteriores que instalabas en vez del i3


#8

Ni modo, instale Debian Net-install para poder instalar el grub y hacer un backup de mi Windows 7. En la instalación de Debian hay un paso que dice algo así como “Presiona No para no forzar la instalación UEFI , si presionas sí no podrás arrancar otros sistemas operativos”, y justamente eso creo que sucede con Manjaro, no me da esa opción.

Instalare de nuevo Manjaro I3 ya que es una distro que me pareció fantástica.


#9

check carrefully on boot USB with bios
if you see : USB disk n ( boot and install MBR )
if you see also : USB disk n/ partition 2 ( boot and install EFI )


#10

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.