Error 2 while upgrading / building AUR packages python2 and ceph-libs

I’m having trouble upgrading 2 AUR packages, python2 and ceph-libs.
Yay exits with this:

Error 2
make: Leaving directory ‘/home/user/.cache/yay/ceph/src/ceph-17.2.5/build’
==> ERROR: A failure occurred in build().
→ error making: ceph (ceph-libs)

I’d consider just removing the packages, but pamac says they’re installed as a dependency for another package. But when doing pactree -r ceph-libs (or python2) I’m not getting any useful information, it just looks like they are installed as dependencies of themselves:

pactree -r ceph-libs

pactree -r python2

I guess maybe pactree can’t show the reversed dependency since those programs are coming from AUR.

So 2 questions:

  1. How to resolve “Error 2”?
  2. How to check which programs depend on a specific package when that package was installed from AUR?

3. When selecting those packages to be removed by pamac, it seems nothing else will be removed (tried this to check if something depends on these packages). Could they be “leftovers” after a system upgrade a few weeks ago?

Some package can be dropped from Manjaro repositories, and if you have AUR enabled in your Pamac settings then it will try to update from AUR if the packages exist on the AUR. I think this is the case for ceph-libs and python2

Have you tried pacman -Qi ceph-libs?

It doesn’t give helpful information either, unfortunately:

Install Reason : Installed as a dependency for another package

But thanks anyway, that command gave more info than pactree

I’ll mark this as solution and take my chances removing them. I hope the parent program will throw a useful error if they’re still needed.

This output is normal: those packages were indeed required dependencies when first installed.
A package formerly installed as a dependency is not automatically removed during an update which removes that requirement. You now have no package that depend on those, you can remove them.

pactree computes the dependency tree based on the local package database by default. The package repository is thus irrelevant in this case.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.