Erreur GPG avec Manjaro OpenBox 18.02

#1

Bonjour,

J’aimerai installer Manjaro OpenBox 18.02 en dual boot avec mon Windows 10 qui lui, est déjà installé sur mon SSD.

Le but étant d’avoir en dual boot sur SSD Windows 10 et Manjaro et d’avoir sur mon autre disque dur, une partition pur mes document W10 et une partition pour Monjaro qui contiendrait tout mon /home.

L’installation se déroule normalement, je lance donc une mise à jour :

sudo pacman -Syu 

Les mises à jours se lancent correctement, mais au bout d’un moment, mon écran devient noir ( pas en mode veille… ) et se remet sur la page de login. J’entre donc mon mot de passe et là, quand je tete un super+enter pour lancer un terminal, j’ai une fenêtre pop-up qui apparaît :

Failed to execute default Terminal Emulator.
Input/output error.

Impossible d’ouvrir quoi que ce soit… Sauf Xterm via le menu. Donc je le lance, je retente un :

sudo pacman -Syu 

Et là, succession d’erreur :

Error: GPGME error: Invalid crypto engine
Error: accountsservice: missing required signature
:: File /var/cache/pacman/pkg/accountsservice-0.6.54+0+g204a4ab-2-x86_64.pkg.tar.xz is corrupted ( invalid or corrupted package ( PGP signature)).
Do you want to delete it [Y/n]

Si je fais Y, la même erreur apparaît mais avec d’autres paquets :

  • alsa-lib-1.1.8-1-x86_64.pkg.tar.xz packages
  • libxau-1.0.9-1-x86_64.pkg.tar.xz
  • atk-2.32-1-x86_64.pkg.tar.xz

J’ai testé :

sudo pacman-key --init
pacman-key --populate archlinux manjaro
pacman-key --refresh-keys

Mais rien n’y fait.

Ce qui est étrange c’est qu’avec le même iso, la même connexion internet ( la 4g de mon smartphone ), l’installation et les mises à jours se font sans problèmes sur une machine virtuelle sous VMware…

Je précise que mon pc est un MSI GL73 8RD, au cas où.

Auriez-vous une idée pour résoudre ce problème ?

Merci d’avance !

#2

La dernière iso pour la version Openbox semble assez vieille, et on a eu une mise à jour difficile il n’y a pas longtemps, nécessitant de la passer en TTY. Sinon c’est risquer de se retrouver coincé par une mise à jour partielle.
Vu que tu viens d’installer, le plus simple serait de réinstaller, et que tu effectues la première passe de mise à jour en TTY.

#3

bonjour,
même problème ici mais avec un autre paquet

Tu peux sans doute tenter de remplacer readline par ton paquet accountsservice puis par le fichier accountsservice-0.6.54+0+g204a4ab-2-x86_64 …