Erasing of text not working in Libreoffice Calc 6.2.0.3

kde
libreoffice

#1

First of all hello everyone!

I have a very weird problem (bug)…
After the update to 6.2.0.3 backspace has stopped working in Calc while editing text in a cell or in the equation input box. During typing, I would expect that pressing backspace would erase the character at left to the cursor, but nothing happens when I press the key. The delete key works. :thinking:

Also the backspace key is working everywhere else, including Libreoffice Writer and Impress.

I tried re-installing Libreoffice and renaming the ~/.config/libreoffice folder. This did not help.
Please let me know if what additional information I can give you since I currently feel quite lost…


Problems with copy pasting after Feb 19 update
#2

I do not have problem erasing characters with backspace on Manjaro Cinnamon on my side with libreoffice 6.2.0-3.

Perhaps it is DE-dependent? I see someone said having a similar issue with LO 6.2.0, but according to his profile, he uses KDE.

EDIT: It seems to be a regression in Libre Office itself when used in KDE. It has been reported in LO bug tracker.
https://bugs.documentfoundation.org/show_bug.cgi?id=122238

It’s not the only problem with LO 6.2.0 with KDE. For example, on Arch (and on the topic I linked earlier), some users reported to have problem when using Copy + Paste for example.
https://bbs.archlinux.org/viewtopic.php?id=244195


#3

I seem to have the same problem, backspace not working in a cell.

KDE Plasma / Unstable branch / LO Version: 6.2.0.3

:Edit: Shift and backspace does the correct thing.


#4

Thanks. This seems to be the issue as I am also using KDE.

It seems to work if I force Libreoffice to use the GTK3 theme, as shown in https://wiki.archlinux.org/index.php/LibreOffice#Theme:

export SAL_USE_VCLPLUGIN=gtk3; libreoffice --calc

Also according to the links posted by Frog, it should be fixed in 6.2.1.


LibreOffice Calc: Löschtaste funktioniert nicht mehr
#5

Thanks for posting this. Fixes the issue with Writer not being able to copy or paste either.

export SAL_USE_VCLPLUGIN=gtk3; libreoffice --writer

#6

I fixed it with Tools→Options→LibreOffice Calc→Compatibility→Key Bindings→OpenOffice.org legacy, then a restart.