Erase/format Samsung Sata SSD

Hello, I am really new to Manjaro and among other problems I’m facing this one is the biggest thus far.

I am trying to erase/format my spare Samsung SSD so that I can use it in Manjaro, right now it is formatted to work in windows since I was using it in windows before.

I did try using google but all google gives me are results for when someone is actually installing Manjaro for the first time instead someone like me who has Manjaro already and is trying to figure out how to erase/format their SSD within Manjaro.

Any way, I opened up PartitionManager as suggested by a post I found with google but when I go to the SSD in the list using the option “New Partition Table” is grayed out. In fact, on every drive I have this is grayed out. The only drive I have that it’s not grayed out is my USB flash drive.

Help would be appreciated. Thanks for your time.

1 Like

Did you unmount de SSD first?


More Infos would be nice, are you using KDE?

Could you get some screens or some logs?

btw. welcome to Linux Manjaro :slight_smile:

Be aware if you Click on New Partition Table the whole SSD Partitions getting lost.

No I haven’t done this yet.

I believe I’m using KDE Plasma.

I’m not sure what screencaps you’d like.

Thanks, I wanna try to learn linux, I know the bare minimum right now.

Small update

I have mounted the SSD which didn’t think of at all from the start, created a new partition table and then made the unallocated space allocated. Now I’m stuck again because when I mount or unmount the drive, it doesn’t seem to matter, it still shows up as the old SSD title and the same contents as before with windows.

Have you rebooted?

Just now and still no different.

This looks to me, that you only created pending operations (in KDE Partition Manager, right?) and forget to press apply button after that, take a look at the lower bottom window.

1 Like

This is what happens.

It shows an error during the “shred” phase. You need to provide the detailed output to show why it failed.

If you’re willing to go the more “advanced” route, you can resort to using the command line, rather than the GUI partition manager.

Right except that once it aborts the window freezes and the only way to get it working again seems to be to kill the process of the KDE partition manager.

I’ve tried to do this a few times now, each time with an error / saying it aborted and the window freezing up.

What is the more complicated way through the terminal? Maybe it’s somehow easier or works better.

Substitute sdX and sdX1 for the proper device and partition, such as sdh and sdh1.

BE VERY CAREFUL as your “drive letter” can change between reboots and based on which port it is plugged into, so that sdb can next time be sdf, and so forth.

You can use /dev/disk/by-id/ata-SAMSUNG-blahblahblah if you prefer to use the device name based on its serial number. To use the partition, just append -part1 to the end of the path.

  1. Make sure you have exfatprogs instead of exfat-utils.
sudo pamac remove exfat-utils

sudo pamac insall exfatprogs
  1. Clear the start of the device.
sudo dd if=/dev/zero bs=512K count=64 of=/dev/sdX status=progress
  1. (optional) Wipe the entire device using either /dev/urandom or the SSD’s built-in secure wipe.

  2. Create the partition table and partition. (Yes, use “NTFS” fs-type.)

sudo parted /dev/sdX

       mktable gpt

       mkpart primary NTFS 0% 100%

  1. Then format the first (and only) partition with exfat.
sudo mkfs.exfat /dev/sdX1
  1. Finally, for good measure…
sudo partprobe -s

UPDATE: I’ll leave the above steps for posterity, but the solution was much simpler. As suspected by @chomsky, the SSD was not unmounted prior to issuing the KDE Partition Manager commands. Hence, @lahpyrcopa could not modify nor reformat the drive.

For me the terminal way looks really advanced/complicated, maybe you can boot with a USB Stick/DVD and format your drive with Windows Partition Manager or maybe it works with KDE Partition Manager under USB Livelinux?

What happends when you only change the Partition Table from your Samsung Drive or only shred without creating a partition?
Btw. on your second screenshot where the error occurred, you missed to click/open Details… that info could also help or is it freezed there already? In this case, maybe you have to click on details very quick… befor it can freeze :wink:

Edit: It also could be highly possible that there is a sector damage on your SSD, i know a few tools for Windows that can repair/block this damage sectors, but i have no clue how to fix this issue under Linux, maybe someone can show us a Tool for Linux to scan broken sectors?

This process took entirely way too long to happen, I feel like that any way.

In any case I FINALLY got it to erase into an NTFS drive.

In order for the drive to properly erase/format I had to unmount it which is the error given in the details panel and I couldn’t see the details panel unbeknownst to me because for some reason several windows were opened on my second monitor.

Thanks for all of your help. :grinning_face_with_smiling_eyes:

KDE Partition Manager: SMART Status Report

KDE Partition Manager: SMART Status Report

Date: 05/10/2021 10:26
Program version: 21.08.1
Backend: pmsfdiskbackendplugin (1)
KDE Frameworks version: 5.85.0
Machine: Linux jesse-ms7922 5.13.19-2-MANJARO #1 SMP PREEMPT Sun Sep 19 21:31:53 UTC 2021 x86_64

Delete partition ‘/dev/sdb1’ (465.76 GiB, ntfs)

Job: Delete file system on ‘/dev/sdb1’

Command: wipefs --all /dev/sdb1

Delete file system on ‘/dev/sdb1’: Success

Job: Delete the partition ‘/dev/sdb1’

Command: sfdisk --force --delete /dev/sdb 1

Delete the partition ‘/dev/sdb1’: Success

Delete partition ‘/dev/sdb1’ (465.76 GiB, ntfs): Success

Create a new partition (465.76 GiB, exfat) on ‘/dev/sdb’

Job: Create new partition on device ‘/dev/sdb’

Command: sfdisk --force --append /dev/sdb

Create new partition ‘/dev/sdb1’: Success

Job: Create file system ‘exfat’ on partition ‘/dev/sdb1’

Command: mkfs.exfat /dev/sdb1

Command: sfdisk --part-type /dev/sdb 1 7

Create file system ‘exfat’ on partition ‘/dev/sdb1’: Success

Job: Set the file system label on partition ‘/dev/sdb1’ to ""

Command: exfatlabel /dev/sdb1

Set the file system label on partition ‘/dev/sdb1’ to "": Success

Job: Check file system on partition ‘/dev/sdb1’

Command: fsck.exfat /dev/sdb1

Check file system on partition ‘/dev/sdb1’: Success

Create a new partition (465.76 GiB, exfat) on ‘/dev/sdb’: Success

:point_up_2: :point_up_2: :point_up_2:This was the very first reply in the thread. :point_up_2: :point_up_2: :point_up_2:

I marked @chomsky’s post as the solution, since it simplifies the answer for future readers of this thread, and moots the complexities from the latter replies.

Fair enough and my mistake too, I read chomsky’s reply as “mount” rather than “unmount”. :joy:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.