'Erase Disk' default's way of installing solely Manjaro yields no operating system

I have downloaded 'manjaro-gnome-18.0.4-stable-x86_64.iso', and
the checksum was OK. Then, I made a bootable USB-Stick.

My system was Ubuntu 14 alongside Windows 7 (see attached image).
The 'Erase Disk' option offered, by default, a very convenient option, which was to remove everything and create a unique Manjaro operating system (see attached image).

The installation finished OK, and when rebooting, no operating system is detected

.

Boot from USB and look on sda /boot/ for linux4xxx, initramfs-xx.

You write no OS is detected, what you see?
Ubuntu Grub, all black?


I see the following:

I'm sorry, I'm not sure to understand - Do you mean

cd /dev/sda

?

I receive

Not a directory

In live System use file browser / gparted and look if something inside the volume.
It is HP laptop?
You check "F2" System ?

In live System post output from inxi -Fxxxz

The partitioning is not correct this way.

You need a /boot/efi vfat (FAT32) partiton with 100 MB
/boot with 1GB
and so on.

I am not surprised. that the computer doesn´t want to boot.

Maybe, if OS is installed, per sudo manjaro-chroot or

sudo pacman -S mhwd-chroot
sudo mhwd-chroot
grub-install /dev/sda
grub-install --recheck /dev/sda
update-grub

Needed if only Manjaro is on ssd? He delete win and ubuntu.
But I am not the boot guru in this forum :smiley: ( @gohlip ) :wink:

1 Like

There is no OS installed...

So no more answer needed, install again and hope the hard disk is Ok. Check it first.

I'm sorry I am not sure if I am understanding your point. Let me just kindly clarify (please don't get me wrong, thanks a lot for your support).

There is no OS installed in the sense that there is no Operating System (i.e. Manjaro or any other -since ubuntu and win were removed- ).
When switching on the laptop, the black screen uploaded in my previous answer is what I get.

No offense :slight_smile:
If the hard disk is ok (good) and really empty you can only install new,
we know nothing about your laptop, 1 or 2 hdd/ssd and so on ... so we cant help.

And no answer from you
In live System use file browser / gparted and look if something inside the volume.
It is HP laptop?
Do you check "F2" System ?

In live System post output from inxi -Fxxxz

@David1
Not sure if you installed in uefi or bios-legacy mode.
But use this first post to boot into your installed manjaro OS.
And provide the information as listed in that post.

You may have to use [Complicated Setup] section to boot, but if there is a grub.cfg generateded during the installation you can try with the [Simple First Start].

I think the OS is installed.

As a note (and thinking aloud), I think (not sure because I never use this) the "Erase Disk" at the installer should not be used. I think that facility does not create any partition table. Not sure if the installer at that point ask if the user wants 'msdos' or 'gpt' (but I don't think so). If it does not ask what partition table to use, I wonder how the installer knows what table to use. Perhaps if the install media is booted in uefi, it generates gpt and if bios-legacy, msdos. But there have been (3) cases here where the user has not has the boot flag set and find the installation unbootable. One should always have the disk partition table set instead of merely erasing the disk.

2 Likes

Good! :wink:

Ok, so in the Live USB, I do

lsblk

loop

This is the result of running Gparted in the Live USB:

Yes.
HP Folio 1040

As shown in the black screen photo I posted before, there is a "F2" option indeed. Hitting this button only redirects me to the BIOS.

Just saw your info, drives is 'supposedly' mbr. So start the install media in bios-legacy and when booted at installed OS, provide the info, copied for your convenience.

efibootmgr -v
sudo parted -l
sudo blkid
findmnt -s
findmnt /boot/efi

parted -l --> small 'L', not 'one'. all disk do not omit, do not truncate.
if error message anywhere, print error message. continue to next command.

Oh, PRINT please, not screen shots. We will need to copy the output you provide.
Better for you. Really.

If you can follow, David, if the drive is sda. do this at the terminal when booted up,

sudo parted /dev/sda set 1 boot on

where sda1 is the manjaro partition. if it is not, use the manjaro partition in your case.
But from your output, when you provide, we can determine that.

1 Like

Sorry if I misunderstand, but how can I possibly do this if there is no OS installed ?

You said... and I quoted...

Usually if the installation proceeds and ended without error; maybe just bootloader not installed..python3 blah blah blah.. the OS is installled.

Anyway, at the link, if you do

grub> search.file /etc/manjaro-release

and if there is an output. it usually means you have a good installation. Just won't boot, normally (but will boot with the link). And if there is kernels and initrd files (initramfs) in /boot, it will boot, graphics notwithstanding.

To further explain, grub will boot any OS (with kernels) even if the OS has other bootloaders or no bootloader. So, that's what we are doing here. Unless ......

Is there? We can find out right? With

grub> search.file /etc/manjaro-release

Or with

grub> ls /boot/

or with... your output.

2 Likes

I'm sorry but it is not clear which 'link' you are referring to


:man_shrugging:

1 Like

How old is the target machine and does it have UEFI? If so, is your machine configured to boot in EFI mode instead of ms-dos? check the BIOS settings (look for CSM or legacy mode being enabled) and make sure you booted the manjaro media in the right mode.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark