Equalizador de som

pulseaudio

#1

Já testei o Pulseaudio Equalizer e o Pulseeffects e ambos têm os mesmos problemas como som distorcido, “crackling” ou ate mesmo parar de funcionar. Procuro alguma forma de controlar os graves e agudos como tem no Windows nas definições de som. Há uns anos usei o alsa-equal e esse funcionava muito bem mas agora tudo usa pulseaudio. Alguém sabe como configurar algum destes programas correctamente e com óptima qualidade de som ou alternativas.


#2

Depois de muito mexer na parte de áudio do Manjaro, eu consegui deixar ele excelente da seguinte forma:

  • Instale o pulseaudio-equalizer-ladspa e configure no seu gosto (eu particularmente achei o ladspa melhor do que o equalizador “original” do Pulse Audio).

  • Crie um arquivo chamado daemon.conf no diretório ~/.config/pulse/ (caso não exista) e coloque os seguintes comandos:

default-sample-format = s16le
default-sample-rate = 48000
alternate-sample-rate = 44100
default-sample-channels = 2
default-channel-map = front-left,front-right
default-fragments = 2
default-fragment-size-msec = 125
resample-method = soxr-vhq
enable-lfe-remixing = no
high-priority = yes
nice-level = -11
realtime-scheduling = yes
realtime-priority = 9
rlimit-rtprio = 9
rlimit-rttime = -1
daemonize = no
  • Faça um backup do arquivo asound.conf no diretório /etc/ e substitua seu conteúdo pelo seguinte:
# use this as default
pcm.!default {
  type plug
  slave { pcm "jack" }
}
 
ctl.mixer0 {
  type hw
  card 2
}
 
# pcm type jack
pcm.jack {
  type jack
  playback_ports {
    0 system:playback_1
    1 system:playback_2
  }
  capture_ports {
    0 system:capture_1
    1 system:capture_2
  }
}
  • Reinicie o pulseaudio daemon:
pulseaudio -k
pulseaudio --start

Caso o segundo comando retorne um erro, espere uns 10 segundos e digite-o novamente.

  • Certifique-se de o dispositivo de áudio selecionado comece com “LAPSA Plugin Multiband EQ”

Caso o áudio continue com crackling experimente substituir o “s16le” na primeira linha do daemon.conf por alguma das seguintes opções:

s16be, s24le, s24be, s24-32le, s24-32be, s32le, s32be float32le, float32be, ulaw, alaw

e reinicie o pulseaudio novamente.


#3

Muito obrigado pela ajuda. Sem duvida melhorou bastante, mas ainda não está perfeito.
Por exemplo, no youtube usando o firefox se estiver a reproduzir uma musica e abrir outra aba com outra voltam logo os engasgos e “cracklings”.


#4

Experimenta installar o realtime audio kernel.


#5

Experimentou fazer isso?
https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Glitches.2C_skips_or_crackling


#6

Nada resulta.


#7

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.