Epson WF-2860 installation support help request

Hello Everyone,

I just purchased an Epson WF-2860 Multifunction printer, and I am struggling to get it to work.

The Printer is connected into the network, and it can be found using the printer settings, including IP Address.
A number of the printers appear and when choosing the options one by one, the error message “Failed to add new printer”.

I had called Epson, and the Technical support person freaked out…

Would I be able to get assistance please.

Thank you in advance,

see also: Printing - Manjaro

In terminal:

pamac build  epson-inkjet-printer-escpr2    OR possibly

pamac build  epson-inkjet-printer-escpr

Thank you for your support so far.
Unfortunately the link didn’t work. It seems outdated as a number of replies in terminal showed ‘does not exist’

Just having a try with the Printing-Manjaro option

Thank you for providing the support.
The CUPS option worked a treat.

There is a scanning option, however, it is saying to install the Epson Event Manager software, which I believe is not available for Linux. Is there a way that scanning directly to your computer can be done?

See: SANE - ArchWiki

What is “it”? Where is this message coming from?
Have you tried to install imagescan? It is available in the (community) repositories. Install via pamac GUI or in terminal:

pamac install imagescan

Additional info:

Question and answer posed on Ubuntu forum:

My apologies. When I mentioned ‘it’, I meant the printer itself.

Thank you for everything so far.

Hello again everyone,

I just wanted to advise that everything regarding the Printer & Scanner functions are success stories.

I apologise I didn’t advise sooner. Thank you very much to everyone.