Eog opening VERY slowly. Why?

I have long used eog as a lightweight, quick way to view images. Today I noticed it is taking about 30 seconds to open a simple image.

I have 36 GB of free RAM so that’s not an issue. Imagemagick reports this about the image:

$ identify MyClass.png
MyClass.png PNG 290x277 290x277+0+0 8-bit sRGB 15337B 0.000u 0:00.000

It was generated by dot. Just a simple, small PNG. I can open it instantly using viewnior or display.

Although I have workarounds, I would like to understand why eog is so slow, and fix it. I use XFCE and am not overly familiar with the Gnome ecosystem, so pointers would be useful.

FWIW, I am not seeing anything in syslog (journalctl -f --system) when I run eog. I tried eog with -g, -w and -n with no noticeable difference. In case anyone wants to know the value of $DISPLAY it is :0.0

What about just launching eog from terminal?

I did that, no messages. Just silence and a looong wait. At first I thought it was hung and was just ^C after a while, then I let it run for a while and it eventually showed up.

Care to share an inxi:

inxi -Fazy

Maybe also check for any failed services too:

systemctl --failed

Is it the portal gnome vs GTK thing from the previous stable update?

1 Like

Here are the diagnostics requested:

$ inxi -Fazy
  Kernel: 5.15.122-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=c5dd873d-0d4f-48aa-b0a3-5bbcae2e8314 rw quiet
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 7 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: ASUS product: All Series v: N/A
    serial: <superuser required>
  Mobo: ASUSTeK model: X99-DELUXE v: Rev 1.xx serial: <superuser required>
    UEFI: American Megatrends v: 1801 date: 05/15/2015
  Info: model: Intel Core i7-5820K bits: 64 type: MT MCP arch: Haswell
    gen: core 5 level: v3 note: check built: 2013-15 process: Intel 22nm
    family: 6 model-id: 0x3F (63) stepping: 2 microcode: 0x49
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 15 MiB desc: 1x15 MiB
  Speed (MHz): avg: 1562 high: 2577 min/max: 1200/3600 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 2173 2: 1199 3: 1234
    4: 1802 5: 1199 6: 2577 7: 1901 8: 1199 9: 1200 10: 1220 11: 1427 12: 1613
    bogomips: 79177
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GM200 [GeForce GTX 980 Ti] vendor: Micro-Star MSI
    driver: nvidia v: 535.86.05 alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-07) arch: Maxwell code: GMxxx
    process: TSMC 28nm built: 2014-19 pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:17c8 class-ID: 0300
  Device-2: Logitech HD Pro Webcam C920 driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-9.4:7
    chip-ID: 046d:082d class-ID: 0102 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
    compositor: xfwm v: 4.18.0 driver: X: loaded: nvidia gpu: nvidia
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 8560x1440 s-dpi: 96 s-size: 2265x381mm (89.17x15.00")
    s-diag: 2297mm (90.43")
  Monitor-1: DP-0 pos: left res: 2560x1440 hz: 120 dpi: 109
    size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
  Monitor-2: DP-2 pos: primary,center res: 3440x1440 hz: 60 dpi: 110
    size: 797x334mm (31.38x13.15") diag: 864mm (34.02") modes: N/A
  Monitor-3: DP-4 pos: right res: 2560x1440 hz: 120 dpi: 109
    size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 535.86.05 renderer: NVIDIA GeForce GTX 980
    Ti/PCIe/SSE2 direct-render: Yes
  Device-1: Intel C610/X99 series HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8d20
    class-ID: 0403
  Device-2: NVIDIA GM200 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0fb0 class-ID: 0403
  Device-3: Kingston HyperX SoloCast driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-9.3:5
    chip-ID: 0951:170f class-ID: 0300
  Device-4: Logitech HD Pro Webcam C920 driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-9.4:7
    chip-ID: 046d:082d class-ID: 0102 serial: <filter>
  API: ALSA v: k5.15.122-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.75 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl,pavucontrol
  Device-1: Intel Ethernet I218-V vendor: ASUSTeK driver: e1000e v: kernel
    port: f020 bus-ID: 00:19.0 chip-ID: 8086:15a1 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 08:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-3: Broadcom BCM4360 802.11ac Wireless Network Adapter
    vendor: ASUSTeK driver: wl v: kernel modules: bcma pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 09:00.0 chip-ID: 14e4:43a0 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-1: ASUSTek Broadcom BCM20702 Single-Chip Bluetooth 4.0 + LE
    driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1
    bus-ID: 3-6:2 chip-ID: 0b05:180a class-ID: fe01 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
  Local Storage: total: 7.5 TiB used: 2.08 TiB (27.7%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SanDisk model: Ultra 3D NVMe
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 211070WD temp: 38.9 C
    scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT250BX100SSD1
    size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: MU02 scheme: MBR
  ID-3: /dev/sdb maj-min: 8:16 vendor: Toshiba model: DT01ACA300
    size: 2.73 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: ABB0 scheme: GPT
  ID-4: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST4000DM004-2CV104
    size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 5425 serial: <filter> fw-rev: 0001 scheme: GPT
  ID-1: / raw-size: 55.46 GiB size: 54.42 GiB (98.11%) used: 46.1 GiB (84.7%)
    fs: ext4 dev: /dev/sda5 maj-min: 8:5
  ID-2: /boot/efi raw-size: 1000 MiB size: 998 MiB (99.80%)
    used: 264 KiB (0.0%) fs: vfat dev: /dev/sda4 maj-min: 8:4
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 32 GiB used: 17.6 MiB (0.1%)
    priority: -2 dev: /dev/sdb4 maj-min: 8:20
  System Temperatures: cpu: 41.0 C mobo: N/A gpu: nvidia temp: 60 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 31%
  Processes: 416 Uptime: 2d 20m wakeups: 0 Memory: total: 64 GiB note: est.
  available: 62.71 GiB used: 16.49 GiB (26.3%) Init: systemd v: 253
  default: graphical tool: systemctl Compilers: gcc: 13.1.1 alt: 6
  clang: 15.0.7 Packages: 2316 pm: pacman pkgs: 2308 libs: 526
  tools: pamac,trizen pm: flatpak pkgs: 8 Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.28

And I ran the systemctl command before and after an eog invocation:

[~]$ systemctl --failed
0 loaded units listed.
[~]$ systemctl --failed
0 loaded units listed.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Nothing super obvious that would be new… but

This may become a problem soon. Try to free up some space.

This is just general info, as of course this didnt change over time for you:

Its an old board with an old BIOS … there are updates though:

You’ve probably got xdg-desktop-portal-gnome installed, replace it with xdg-desktop-portal-gtk.

I was ignoring this because of ‘eye-of-gnome’ … but realize the user is actually on XFCE.
So it is totally possible.


pacman -Qs xdg-desktop-portal

If gnome is there

sudo pacman -Rdd xdg-desktop-portal-gnome && sudo pacman -Syu xdg-desktop-portal-gtk

I was unable to remove xdg-desktop-portal-gtk as it was required by xdg-desktop-portal, which is in turn required by flatpak, lutris and steam. I did reinstall xdg-desktop-portal-gtk, and removed xdg-desktop-portal-gnome.

No clue what effect that had, but eog is opening faster now, about 2 sec instead of 30 sec. (I also freed up some disk space which could have affected things, and did a full upgrade.)

Thanks for the help

Thats what the -Rdd was for … ignores depends (dont use usually).

It is a known bug. Listed in every release announcement since … june ?

(though users not on gnome desktop should never have installed portal-gnome)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.