Endlessly asking 'Replace xcas with community/giac?'

Hi there,
I have an issue with my last update. When I do sudo pacman -Syu it asks me

:: Replace libgiac with community/giac? [Y/n]
:: Replace xcas with community/giac? [Y/n] 

I put Yes and it installs the packages as expected. Then, if I do again a sudo pacman -Syu it asks me again the same question, and (re?)install the packages if I say yes. And if I answer NO, it keeps asking the question too.
The packages in question seem to be
Packages (3) giac-1.7.0.3-3 libgiac-1.7.0.3-2 [removal] xcas-1.7.0.3-2 [removal]
I have the same issue using pamac.
I have no idea why it does this nor what to do.
Thanks.

I’m using Kernel: 4.19.189-1-MANJARO on i3wm (I have also gnome installed).

7 Likes

Having the same issue here. If I say yes to that dialogue, next time pacman asks:

:: Replace giac with community/xcas? [Y/n]

If I say yes to that then the loop continues. I’m running the 5.12.1 kernel with KDE.

1 Like

Been experiencing the same thing for over a week. It affects yay also.
Kernel: 5.11.18-1-MANJARO
Desktop: KDE Plasma 5.21.4

3 Likes

Adding IgnorePkg = giac in /etc/pacman.conf worked as a temporary fix for me.

1 Like

Thanks! That’s helpful, at least now it doesn’t ask the same question anymore!
But it (pacman or similar) still seems to consider that the packages in question should be replaced. I mean, I don’t know how to fix the problem at its origin (I don’t know if I explain myself).

It looks like the problem got solved recently, you can delete the IgnorePkg line and update again, replace the packages one last time and it shouldn’t ask again.

If an issue like this happens again in the future you can report it to package maintainers.

This issue is still happening to me and in my case it appears after I try to install sagemath through pacman -S sagemath. Probably because it is one of its dependencies. I was about to open a thread on this problem but maybe I am better off trying to speak with the package maintainers.

I couldn’t find any issues on a clean install, I think it would be better to make a thread unless the problem occurs with every system.

Hi,
I still have the same issue too.

Same issue here for over a week.

System: Kernel: 5.4.116-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.21.4

The problem is not resolved without the temporary fix @Stringbean suggested.

I suspect that the root cause lies in the sagemath package. Once the change is fixed there, it should disappear. May I ask whether everyone reporting this problem has sagemath installed?

1 Like

I have sagemath intalled.

1 Like

I also have sagemath installed . I have just sent an email to the sagemath packager – Antonio Rojas, explaining the issue. Hopefully he will be able to help us out :slightly_smiling_face: .

1 Like

This was the reply I got from the packager,

Hi,
I’m sorry but this is a Manjaro specific issue that I can’t do anything about. Please report it to whoever maintains the Manjaro repos.

I’m at a loss, I don’t know who actually are the Manjaro repos maintainers. Does anyone knows?

It appears that someone in the gods’ council checked this thread :joy:. There was a major update just now and I tried to install sagemath and the update loop is no more. Problem solved.

1 Like

I just remembered I am on testing branch. Was wondering why it was fixed only for me

I noticed that before the update, installing sagemath downloaded the 9.2.something version and after the update it downloaded the 9.3. Maybe it had to do with that.

Yes! it is OK now.

Thank everybody.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.