Encrypted boot partition grub error: unknown filesystem

I updated Manjaro xfce this Monday and things booted fine. However, yesterday my screen went blank and I have to restart, only to get an ‘unknown filesystem’ error after entering my grub password.
I tried to access my files via a portable iso ( also found some threads with similar symptoms), but since my boot partition is encrypted, no luck. Anything I could try?

Some info:

efibootmgr -v
BootCurrent: 0004
Timeout: 1 seconds
BootOrder: 0004,0003,0005,0006,0002,0001
Boot0001* Hard Drive BBS(HD,0x0)…GO…NO…u.S.a.n.D.i.s.k. .S.D.S.S.D.A.2.4.0.G…A…>…Gd-.;.A…MQ…L.7.1.9.2.0.8.7.4.1.1.3.0. . . . . . . . …BO…NO…u.S.T.2.0.0.0.D.M.0.0.6.-.2.D.M.1.6.4…A…>…Gd-.;.A…MQ…L. . . . . . . . . . . . .4.Z.7.Z.Q.X.8.K…BO
Boot0002* Removable Drive BBS(Floppy,0x0)…GO…NO…y.U.F.D. .2…0. .S.i.l.i.c.o.n.-.P.o.w.e.r.1.6.G.P.M.A.P…A…F…Gd-.;.A…MQ…L.P.1.6.0.1.4.5.0.0.7.0.B.6.6.E.2.5.D.A.B.D.2.9.7…BO
Boot0003* UEFI: UFD 2.0 Silicon-Power16GPMAP PciRoot(0x0)/Pci(0x7,0x1)/Pci(0x0,0x3)/USB(1,0)…BO
Boot0004* UEFI: UFD 2.0 Silicon-Power16GPMAP PciRoot(0x0)/Pci(0x1,0x3)/Pci(0x0,0x0)/USB(6,0)/CDROM(1,0x32d884,0x8000)…BO
Boot0005* UEFI: UFD 2.0 Silicon-Power16GPMAP, Partition 2 PciRoot(0x0)/Pci(0x1,0x3)/Pci(0x0,0x0)/USB(6,0)/HD(2,MBR,0x0,0x32d884,0x2000)…BO
Boot0006* USB BBS(HD,0x0)…GO…NO…y.U.F.D. .2…0. .S.i.l.i.c.o.n.-.P.o.w.e.r.1.6.G.P.M.A.P…A…F…Gd-.;.A…MQ…L.P.1.6.0.1.4.5.0.0.7.0.A.6.6.D.E.0.2.4.8.5.5.8.8…BO

blkid -o list -c /dev/nul
device fs_type label mount point UUID
/dev/loop0 squashfs /run/miso/sfs/livefs
/dev/loop1 squashfs /run/miso/sfs/mhwdfs
/dev/loop2 squashfs /run/miso/sfs/desktopfs
/dev/loop3 squashfs /run/miso/sfs/rootfs
/dev/sda5 crypto_LUKS (not mounted) fbe4620f-cf74-43c8-b1b8-6da5a8fcc951
/dev/sdb1 ext3 /run/media/manjaro/11aa47a9-8536-478f-83ec-fbd2908d8ddd 11aa47a9-8536-478f-83ec-fbd2908d8ddd
/dev/sdd1 iso9660 MJRO1705 /run/miso/bootmnt 2017-09-16-10-13-30-00
/dev/sdd2 vfat MISO_EFI (not mounted) 7723-A0BA
/dev/sdc1 ntfs Storage (not mounted) 520046B70046A239

sudo parted -l
Error: Invalid partition table on /dev/sda – wrong signature 9ca3.
Ignore/Cancel? ignor
Model: ATA SanDisk SDSSDA24 (scsi)
Disk /dev/sda: 240GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:
Number Start End Size Type File system Flags
1 32.3kB 203GB 203GB extended lba
5 1049kB 3146kB 2097kB logical
Model: ATA ST2000DM006-2DM1 (scsi)
Disk /dev/sdb: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:
Number Start End Size Type File system Flags
1 1049kB 2000GB 2000GB primary ext3
Model: WD My Passport 259F (scsi)
Disk /dev/sdc: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:
Number Start End Size File system Name Flags
1 1049kB 2000GB 2000GB ntfs My Passport msftdata
Model: UFD 2.0 Silicon-Power16G (scsi)
Disk /dev/sdd: 15.5GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:
Number Start End Size Type File system Flags
1 32.8kB 1706MB 1706MB primary boot
2 1706MB 1710MB 4194kB primary esp

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark