Enabling Mouse Scroll Options in KDE

As I said - please verify - and I don't think both should be used - only one :slight_smile:

A good source is https://wiki.archlinux.org/index.php/Xorg

1 Like

Undo the modifications you made, remove the /etc/X11/xorg.conf.d/11-evdev.conf if you created one

sudo rm -r /etc/X11/xorg.conf.d/11-evdev.conf

and first try only with this with no other edits:

sudo ln -s /usr/share/X11/xorg.conf.d/10-evdev.conf /etc/X11/xorg.conf.d/10-evdev.conf

Did that. I can't use my touchpad, but I get all the settings for my usb mouse.

if you remove the mouse from the USB port, does the touchpad and the settings for it works ?

No, the touchpad won't work, even if I reboot without the usb mouse.

Some systems has settings that enables/disables devices when connected.

Does KDE have an option for disabling touchpad when a mouse is attached? It could be such setting - but I don't know - not a KDE user.

1 Like

Yes, it has that option, but sadly the Mouse advanced options will not be enabled without what i mentioned in that post

Both use libinput but KCM_Mouse is failing to simple settings without that file.

KDE has such an option, but it's not activated.

And I can't even select that option now, because it can't find my touchpad.

What suprisingly does work is the simple tab on the touchpad. It recognizes it as a left mouse click.

remove the file /etc/X11/xorg.conf.d/10-evdev.conf reboot so the touchpad is detected and disable the option that the touchpad is disabled when the mouse is connected, add again the file to get the mouse options to advanced ... I hope you get my idea.

Yeah I got it, but as you can see in my screenshot the option is not selected. So it won't disable my touchpad when I connect the usb mouse.

(The option in german says: Touchpad abschalten, wenn eine Maus angeschlossen ist == Disable Touchpad, when a mouse is connected)

can i see the
cat /usr/share/X11/xorg.conf.d/30-touchpad.conf
?

I don't have such a file.
All I got in /usr/share/X11/xorg.conf.d/ is:

10-amdgpu.conf  10-evdev.conf  10-nvidia-drm-outputclass.conf  10-quirks.conf  10-radeon.conf  40-libinput.conf

lets go back a bit
xinput --list

and i will think about something
If the touchpad is not shown, then better remove again the /etc/X11/xorg.conf.d/10-evdev.conf so we have the entire list even if the mouse will not have the advanced options.

1 Like

I removed /etc/X11/xorg.conf.d/10-evdev.conf and this is my output from xinput:

[alex@lightning ~]$ xinput --list
⎡ Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ GAMEING Rapoo Gaming Device Mouse         id=12   [slave  pointer  (2)]
⎜   ↳ GAMEING Rapoo Gaming Device Consumer Control      id=15   [slave  pointer  (2)]
⎜   ↳ USB OPTICAL MOUSE                         id=16   [slave  pointer  (2)]
⎜   ↳ DELL0825:00 06CB:7E92 Touchpad            id=17   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=22   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Power Button                              id=9    [slave  keyboard (3)]
    ↳ Sleep Button                              id=10   [slave  keyboard (3)]
    ↳ GAMEING Rapoo Gaming Device               id=11   [slave  keyboard (3)]
    ↳ GAMEING Rapoo Gaming Device Keyboard      id=13   [slave  keyboard (3)]
    ↳ GAMEING Rapoo Gaming Device System Control        id=14   [slave  keyboard (3)]
    ↳ Intel HID events                          id=18   [slave  keyboard (3)]
    ↳ Intel HID 5 button array                  id=19   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=20   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=21   [slave  keyboard (3)]
    ↳ GAMEING Rapoo Gaming Device Consumer Control      id=23   [slave  keyboard (3)]

This will be a bit tricky as your xinput sees 2 touchpads
Add the following lines to /usr/share/X11/xorg.conf.d/40-libinput.conf

    Option "Tapping" "True"
    Option "TapingDrag" "True"
    Option "DisableWhileTyping" "True"
    Option "AccelProfile" "adaptive"
    Option "AccelSpeed" "0.4"
    Option "SendEventsMode" "disabled-on-external-mouse"

and remove any traces of synaptic.conf file from /etc/X11/xorg.conf.d/ or elsewhere

You can then create the 30-touchpad.conf in /usr/share/X11/xorg.conf.d/ with this lines:

Section "InputClass"
    Identifier "libinput touchpad catchall"
    MatchIsTouchpad "on"
    MatchDriver "libinput"
    Option "Tapping" "on"
    Option "ScrollMethod" "edge"
    Option "TappingDrag" "on"
    Option "TappingDragLock" "on"
    Option "NaturalScrolling" "off"
    MatchDevicePath "/dev/input/event*"
EndSection

and eventually try again the 11-evdev.conf mentioned initially ...

1 Like

Where should I add the lines to the files?
I've got 5 sections, I'm unsure where to add the lines.

Section "InputClass"
        Identifier "libinput pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput keyboard catchall"
        MatchIsKeyboard "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchpad catchall"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput touchscreen catchall"
        MatchIsTouchscreen "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

Section "InputClass"
        Identifier "libinput tablet catchall"
        MatchIsTablet "on"
        MatchDevicePath "/dev/input/event*"
        Driver "libinput"
EndSection

To were it mentions

right under
Driver "libinput"

The thing is, i always had second thought about editing those files, so make sure you revert if is not helping. Try first only with the 30-touchpad.conf + 11-evdev.conf from before.

1 Like

Tried that, but no success.
After that, I also added the lines to /usr/share/X11/xorg.conf.d/40-libinput.conf, but still my touchpad isn't recognized by the system.

I understand. Didn't expected much from this, especially since the 2 touchpads came up in xinput ... i'll have to think to this a bit, but now i have to go. One las thing before i do, in the 11-evdev.conf
add 16 to the line MatchDevicePath "/dev/input/event*"

Section "InputClass"
        Identifier "evdev pointer catchall"
        MatchIsPointer "on"
        MatchDevicePath "/dev/input/event16"
        Driver "evdev"
EndSection

so we restrict that only to the mouse ID event as per xinput.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark